summaryrefslogtreecommitdiffstats
path: root/Tests/CompileCommandOutput/CMakeLists.txt
diff options
context:
space:
mode:
authorManuel Klimek <klimek@google.com>2011-03-31 23:55:00 (GMT)
committerBrad King <brad.king@kitware.com>2011-04-25 17:27:59 (GMT)
commit0e6b05fcba61a1b113b841dd2b3e1e5060866d0e (patch)
tree7c7a2237420f7c6692e7d9d752373d1ceb4ef7cb /Tests/CompileCommandOutput/CMakeLists.txt
parent5674844de4b74d0b66cfc6b8237e631702c43637 (diff)
downloadCMake-0e6b05fcba61a1b113b841dd2b3e1e5060866d0e.zip
CMake-0e6b05fcba61a1b113b841dd2b3e1e5060866d0e.tar.gz
CMake-0e6b05fcba61a1b113b841dd2b3e1e5060866d0e.tar.bz2
Adds a test for the compile command line output.
Diffstat (limited to 'Tests/CompileCommandOutput/CMakeLists.txt')
-rw-r--r--Tests/CompileCommandOutput/CMakeLists.txt11
1 files changed, 11 insertions, 0 deletions
diff --git a/Tests/CompileCommandOutput/CMakeLists.txt b/Tests/CompileCommandOutput/CMakeLists.txt
new file mode 100644
index 0000000..ac39b8b
--- /dev/null
+++ b/Tests/CompileCommandOutput/CMakeLists.txt
@@ -0,0 +1,11 @@
+# a simple C only test case
+cmake_minimum_required (VERSION 2.6)
+project (CompileCommandOutput CXX)
+
+SET(CMAKE_EXPORT_COMPILE_COMMANDS ON)
+set(CMAKE_DEBUG_POSTFIX "_test_debug_postfix")
+ADD_LIBRARY(test1 STATIC "file with spaces.cxx")
+ADD_LIBRARY(test2 SHARED "../CompileCommandOutput/relative.cxx")
+INCLUDE_DIRECTORIES(${CompileCommandOutput_SOURCE_DIR}/../../Source)
+ADD_EXECUTABLE(CompileCommandOutput compile_command_output.cxx)
+TARGET_LINK_LIBRARIES(CompileCommandOutput test1 test2)