summaryrefslogtreecommitdiffstats
path: root/Tests/CompileCommandOutput/CMakeLists.txt
diff options
context:
space:
mode:
authorBrad King <brad.king@kitware.com>2011-05-19 12:11:34 (GMT)
committerBrad King <brad.king@kitware.com>2011-05-19 11:38:06 (GMT)
commit7039d1fd9b817a3ab6c81b4ef313a0bd6e19778d (patch)
tree99fd1835f9717980e5a4953ea0c9a52160e52e65 /Tests/CompileCommandOutput/CMakeLists.txt
parent4268e3d7e92eee0871dac1b92f64e18c374c7b43 (diff)
downloadCMake-7039d1fd9b817a3ab6c81b4ef313a0bd6e19778d.zip
CMake-7039d1fd9b817a3ab6c81b4ef313a0bd6e19778d.tar.gz
CMake-7039d1fd9b817a3ab6c81b4ef313a0bd6e19778d.tar.bz2
Fix CompileCommandOutput test for Make tools not supporting spaces
Use underscores instead of spaces for such Make tools.
Diffstat (limited to 'Tests/CompileCommandOutput/CMakeLists.txt')
-rw-r--r--Tests/CompileCommandOutput/CMakeLists.txt7
1 files changed, 6 insertions, 1 deletions
diff --git a/Tests/CompileCommandOutput/CMakeLists.txt b/Tests/CompileCommandOutput/CMakeLists.txt
index ac39b8b..bd8e305 100644
--- a/Tests/CompileCommandOutput/CMakeLists.txt
+++ b/Tests/CompileCommandOutput/CMakeLists.txt
@@ -4,7 +4,12 @@ project (CompileCommandOutput CXX)
SET(CMAKE_EXPORT_COMPILE_COMMANDS ON)
set(CMAKE_DEBUG_POSTFIX "_test_debug_postfix")
-ADD_LIBRARY(test1 STATIC "file with spaces.cxx")
+IF(MAKE_SUPPORTS_SPACES)
+ SET(test1_srcs "file with spaces.cxx")
+ELSE()
+ SET(test1_srcs "file_with_underscores.cxx")
+ENDIF()
+ADD_LIBRARY(test1 STATIC ${test1_srcs})
ADD_LIBRARY(test2 SHARED "../CompileCommandOutput/relative.cxx")
INCLUDE_DIRECTORIES(${CompileCommandOutput_SOURCE_DIR}/../../Source)
ADD_EXECUTABLE(CompileCommandOutput compile_command_output.cxx)