summaryrefslogtreecommitdiffstats
path: root/Tests/CompileDefinitions/CMakeLists.txt
diff options
context:
space:
mode:
authorStephen Kelly <steveire@gmail.com>2013-05-22 08:25:27 (GMT)
committerBrad King <brad.king@kitware.com>2013-05-24 13:35:43 (GMT)
commit015309fc9f87babaadc2510eb80298b1f2389e8c (patch)
tree99779cfdb503f98a6ed3c9535a964b3742eabeaa /Tests/CompileDefinitions/CMakeLists.txt
parent6aba97642737873921f312e0bbaf18edfabf6e6f (diff)
downloadCMake-015309fc9f87babaadc2510eb80298b1f2389e8c.zip
CMake-015309fc9f87babaadc2510eb80298b1f2389e8c.tar.gz
CMake-015309fc9f87babaadc2510eb80298b1f2389e8c.tar.bz2
Tests/CompileDefinitions: Avoid spaces in defines on VS 6
The VS 6 IDE does not like spaces in definition values so CMake drops them and warns. The Tests/CompileDefinitions test C code that looks for the dropped definitions already knows to skip them, but CMake still warns. Silence the warnings by avoiding such values in the first place on VS 6.
Diffstat (limited to 'Tests/CompileDefinitions/CMakeLists.txt')
-rw-r--r--Tests/CompileDefinitions/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/Tests/CompileDefinitions/CMakeLists.txt b/Tests/CompileDefinitions/CMakeLists.txt
index d3e9a3e..930d220 100644
--- a/Tests/CompileDefinitions/CMakeLists.txt
+++ b/Tests/CompileDefinitions/CMakeLists.txt
@@ -5,6 +5,7 @@ project(CompileDefinitions)
if ("${CMAKE_GENERATOR}" STREQUAL "Visual Studio 6")
add_definitions(-DNO_SPACES_IN_DEFINE_VALUES)
+ set(NO_SPACES_IN_DEFINE_VALUES 1)
endif()
# Use compile flags to tell executables which config is built