summaryrefslogtreecommitdiffstats
path: root/Tests/CompileFeatures/CMakeLists.txt
diff options
context:
space:
mode:
authorBrad King <brad.king@kitware.com>2015-01-19 18:55:29 (GMT)
committerCMake Topic Stage <kwrobot@kitware.com>2015-01-19 18:55:29 (GMT)
commit137a15bf1da72c795d8eeded4ad3848a5692dce6 (patch)
treed9dca30b2b51862a8cb3a92be004094495df6b18 /Tests/CompileFeatures/CMakeLists.txt
parent0898de99cc085fee8534369aea27e9333b53d694 (diff)
parent00194ea752ed02dbe70a808b337cf630735f2894 (diff)
downloadCMake-137a15bf1da72c795d8eeded4ad3848a5692dce6.zip
CMake-137a15bf1da72c795d8eeded4ad3848a5692dce6.tar.gz
CMake-137a15bf1da72c795d8eeded4ad3848a5692dce6.tar.bz2
Merge topic 'SolarisStudio-compile-features'
00194ea7 Help: Add notes for topic 'SolarisStudio-compile-features' bcb04783 Features: Record for SolarisStudio 12.4. 536c535c Features: Adjust cxx_variadic_templates unit test for SolarisStudio. 5d57970d Features: Use variable in cxx_inheriting_constructors test. 69182ce4 Features: Ensure that the cxx_auto_type test is correct.
Diffstat (limited to 'Tests/CompileFeatures/CMakeLists.txt')
-rw-r--r--Tests/CompileFeatures/CMakeLists.txt18
1 files changed, 18 insertions, 0 deletions
diff --git a/Tests/CompileFeatures/CMakeLists.txt b/Tests/CompileFeatures/CMakeLists.txt
index 106f29c..182954e 100644
--- a/Tests/CompileFeatures/CMakeLists.txt
+++ b/Tests/CompileFeatures/CMakeLists.txt
@@ -51,6 +51,17 @@ if (CMAKE_CXX_COMPILER_ID STREQUAL "AppleClang"
)
endif()
+if (CMAKE_CXX_COMPILER_ID STREQUAL SunPro)
+ list(REMOVE_ITEM CXX_non_features
+ cxx_attribute_deprecated
+ cxx_contextual_conversions
+ cxx_extended_friend_declarations
+ cxx_long_long_type
+ cxx_sizeof_member
+ cxx_variadic_macros
+ )
+endif()
+
if (CMAKE_CXX_COMPILER_ID STREQUAL "GNU"
AND CMAKE_CXX_COMPILER_VERSION VERSION_LESS 4.8)
# The cxx_alignof feature happens to work (for *this* testcase) with
@@ -188,6 +199,13 @@ if (CMAKE_CXX_COMPILE_FEATURES)
-DEXPECT_INHERITING_CONSTRUCTORS_AND_FINAL=0
)
endif()
+ elseif (CMAKE_CXX_COMPILER_ID STREQUAL "SunPro")
+ add_definitions(
+ -DEXPECT_OVERRIDE_CONTROL=1
+ -DEXPECT_INHERITING_CONSTRUCTORS=1
+ -DEXPECT_FINAL=1
+ -DEXPECT_INHERITING_CONSTRUCTORS_AND_FINAL=1
+ )
endif()
add_executable(CompileFeaturesGenex genex_test.cpp)