summaryrefslogtreecommitdiffstats
path: root/Tests/CompileOptions/CMakeLists.txt
diff options
context:
space:
mode:
authorBrad King <brad.king@kitware.com>2019-05-17 13:26:38 (GMT)
committerKitware Robot <kwrobot@kitware.com>2019-05-17 13:27:12 (GMT)
commitacc2f022bb538cbd61621f66d64d13b751d23f39 (patch)
tree5cc39f9ca4de99f0efacb822af647074eb3911f4 /Tests/CompileOptions/CMakeLists.txt
parent3020354f7c86f959d707aed2b833692204dd7778 (diff)
parente214abdaab4f8097095a601067b4071194ad01a5 (diff)
downloadCMake-acc2f022bb538cbd61621f66d64d13b751d23f39.zip
CMake-acc2f022bb538cbd61621f66d64d13b751d23f39.tar.gz
CMake-acc2f022bb538cbd61621f66d64d13b751d23f39.tar.bz2
Merge topic 'offer_compiler_lang_generator_expression'
e214abdaab Genex: Add COMPILE_LANG_AND_ID generator expression f84ed796a2 Docs: Generator-expressions remove usage of `CMake-id` Acked-by: Kitware Robot <kwrobot@kitware.com> Merge-request: !3300
Diffstat (limited to 'Tests/CompileOptions/CMakeLists.txt')
-rw-r--r--Tests/CompileOptions/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/Tests/CompileOptions/CMakeLists.txt b/Tests/CompileOptions/CMakeLists.txt
index 15a993c..18896bf 100644
--- a/Tests/CompileOptions/CMakeLists.txt
+++ b/Tests/CompileOptions/CMakeLists.txt
@@ -25,6 +25,7 @@ set_property(TARGET CompileOptions PROPERTY COMPILE_OPTIONS
"-DTEST_DEFINE"
"-DNEEDS_ESCAPE=\"E$CAPE\""
"$<$<CXX_COMPILER_ID:GNU>:-DTEST_DEFINE_GNU>"
+ "$<$<COMPILE_LANG_AND_ID:CXX,GNU>:-DTEST_DEFINE_CXX_AND_GNU>"
"SHELL:" # produces no options
${c_tests}
${cxx_tests}