summaryrefslogtreecommitdiffstats
path: root/Tests/Complex/CMakeLists.txt
diff options
context:
space:
mode:
authorBrad King <brad.king@kitware.com>2016-03-10 14:16:16 (GMT)
committerCMake Topic Stage <kwrobot@kitware.com>2016-03-10 14:16:16 (GMT)
commit612a8b3bd8091372d9e50a81f05dcab8b31ae35c (patch)
treec6978e8f12830b4cab6f484d276ec447621072eb /Tests/Complex/CMakeLists.txt
parente1b0dedc69a7d6eecaf1fe1d2324434aaac67c74 (diff)
parent491b41dd988915a3f00259fa704490dfa2f47dc9 (diff)
downloadCMake-612a8b3bd8091372d9e50a81f05dcab8b31ae35c.zip
CMake-612a8b3bd8091372d9e50a81f05dcab8b31ae35c.tar.gz
CMake-612a8b3bd8091372d9e50a81f05dcab8b31ae35c.tar.bz2
Merge topic 'vs-clang-cl'
491b41dd Help: Add notes for topic 'vs-clang-cl' ad6d27ac Tests: do not build PrecompiledHeader on Clang/C2 a0f0541f Tests: fix PDBDirectoryAndName on Clang/C2 3541af67 Tests: fix Plugin building on Clang/C2 1902c293 Tests: fix complexOneConfig building on Clang/C2 cab2ec11 Tests: fix Complex building on Clang/C2 ada3736c Tests: fix Module.GenerateExportHeader building on Clang/C2 123b7e13 Tests: fix AliasTarget building on Clang/C2 445d4d4b VS 14: Add flag map for -std= to CppLanguageStandard tag in project files 0a785eb4 Features: Clang has no cxx_decltype_incomplete_return_type in MSVC sim mode 2c2ec488 VS: in Clang/C2 toolset, setup correct compiler settings 37afe00f CMakeDetermineCompilerId: Add detection of clang.exe bundled with VS
Diffstat (limited to 'Tests/Complex/CMakeLists.txt')
-rw-r--r--Tests/Complex/CMakeLists.txt7
1 files changed, 7 insertions, 0 deletions
diff --git a/Tests/Complex/CMakeLists.txt b/Tests/Complex/CMakeLists.txt
index 9251ff3..83ca7f4 100644
--- a/Tests/Complex/CMakeLists.txt
+++ b/Tests/Complex/CMakeLists.txt
@@ -2,6 +2,7 @@
# A more complex test case
#
cmake_minimum_required(VERSION 2.4)
+cmake_policy(SET CMP0054 NEW)
project (Complex)
# Test that renaming a built-in works when configured multiple times.
@@ -438,6 +439,12 @@ if (CMAKE_CXX_COMPILER_ID STREQUAL HP AND
set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -AA")
endif ()
+# Clang/C2 in C++98 mode cannot properly handle some of MSVC headers
+if (CMAKE_CXX_COMPILER_ID STREQUAL "Clang" AND
+ CMAKE_CXX_SIMULATE_ID STREQUAL "MSVC")
+ set(CMAKE_CXX_STANDARD 11)
+endif()
+
#
# Create the libs and the main exe
#