summaryrefslogtreecommitdiffstats
path: root/Tests/Complex/Executable/CMakeLists.txt
diff options
context:
space:
mode:
authorBill Hoffman <bill.hoffman@kitware.com>2005-07-29 15:56:31 (GMT)
committerBill Hoffman <bill.hoffman@kitware.com>2005-07-29 15:56:31 (GMT)
commit8dc6db47776e3040c5650ff9b74a0f7793a2c815 (patch)
tree46dba4b499d63efcb88ae399b406f47a3d1bbb6a /Tests/Complex/Executable/CMakeLists.txt
parent4f79ce8f1bea4c3a6259145d052a4c098d34a294 (diff)
downloadCMake-8dc6db47776e3040c5650ff9b74a0f7793a2c815.zip
CMake-8dc6db47776e3040c5650ff9b74a0f7793a2c815.tar.gz
CMake-8dc6db47776e3040c5650ff9b74a0f7793a2c815.tar.bz2
ENH: add new test to make sure c and cxx flags are going to the right files
Diffstat (limited to 'Tests/Complex/Executable/CMakeLists.txt')
-rw-r--r--Tests/Complex/Executable/CMakeLists.txt3
1 files changed, 2 insertions, 1 deletions
diff --git a/Tests/Complex/Executable/CMakeLists.txt b/Tests/Complex/Executable/CMakeLists.txt
index 6c1deb5..e36dc26 100644
--- a/Tests/Complex/Executable/CMakeLists.txt
+++ b/Tests/Complex/Executable/CMakeLists.txt
@@ -3,6 +3,7 @@ CMAKE_MINIMUM_REQUIRED(VERSION 1.3)
# Create exe.
#
SET(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -DTEST_CXX_FLAGS")
+SET(CMAKE_C_FLAGS "${CMAKE_C} -DTEST_C_FLAGS")
# Link to CMake lib
LINK_DIRECTORIES(${Complex_BINARY_DIR}/../../Source)
@@ -14,7 +15,7 @@ SET(COMPLEX_LIBS CMakeTestLibrary;CMakeTestLibraryShared;CMakeTestCLibraryShared
LINK_LIBRARIES(${COMPLEX_LIBS})
ADD_EXECUTABLE(A A.cxx)
-ADD_EXECUTABLE(complex complex)
+ADD_EXECUTABLE(complex complex testcflags.c)
ADD_EXECUTABLE(complex.file complex.file.cxx)
TARGET_LINK_LIBRARIES(complex CMakeLib cmsys cmexpat cmzlib)
IF (UNIX)