summaryrefslogtreecommitdiffstats
path: root/Tests/Complex/Executable/CMakeLists.txt
diff options
context:
space:
mode:
authorSebastien Barre <sebastien.barre@kitware.com>2002-01-19 00:21:43 (GMT)
committerSebastien Barre <sebastien.barre@kitware.com>2002-01-19 00:21:43 (GMT)
commitb6bdbc54fc5f02aa166323855e67b7c7f61fb56e (patch)
tree8fe09182485c9b6c2a3d367ccbb3b6cec4928d97 /Tests/Complex/Executable/CMakeLists.txt
parent747457abb647910742c5e13529894950d3c9ada4 (diff)
downloadCMake-b6bdbc54fc5f02aa166323855e67b7c7f61fb56e.zip
CMake-b6bdbc54fc5f02aa166323855e67b7c7f61fb56e.tar.gz
CMake-b6bdbc54fc5f02aa166323855e67b7c7f61fb56e.tar.bz2
ENH: Increase test + coverage
Diffstat (limited to 'Tests/Complex/Executable/CMakeLists.txt')
-rw-r--r--Tests/Complex/Executable/CMakeLists.txt16
1 files changed, 16 insertions, 0 deletions
diff --git a/Tests/Complex/Executable/CMakeLists.txt b/Tests/Complex/Executable/CMakeLists.txt
index f0df86f..4bd1620 100644
--- a/Tests/Complex/Executable/CMakeLists.txt
+++ b/Tests/Complex/Executable/CMakeLists.txt
@@ -1,4 +1,20 @@
ADD_EXECUTABLE(complex complex)
+
TARGET_LINK_LIBRARIES(complex CMakeTestLibrary)
TARGET_LINK_LIBRARIES(complex CMakeTestLibraryShared)
+FIND_LIBRARY(CMAKE_LIB
+ CMakeLib
+ ${Complex_BINARY_DIR}/../../Source
+ ${Complex_BINARY_DIR}/../../Source/Debug
+ ${Complex_BINARY_DIR}/../../Source/Release
+ ${Complex_BINARY_DIR}/../../Source/MinSizeRel
+ ${Complex_BINARY_DIR}/../../Source/RelWithDebInfo)
+
+TARGET_LINK_LIBRARIES(complex ${CMAKE_LIB})
+LINK_LIBRARIES(${CMAKE_LIB})
+
+# More coverage
+
+INSTALL_TARGETS(/tmp complex)
+INSTALL_PROGRAMS(/tmp complex)