summaryrefslogtreecommitdiffstats
path: root/Tests/Complex/Executable/CMakeLists.txt
diff options
context:
space:
mode:
authorKen Martin <ken.martin@kitware.com>2002-08-28 20:33:38 (GMT)
committerKen Martin <ken.martin@kitware.com>2002-08-28 20:33:38 (GMT)
commit499cef0367b1d578082084fa70e6a6c54ddb0d7a (patch)
tree9ed500e88b67e433412f2556c4abdb4a07ba5df0 /Tests/Complex/Executable/CMakeLists.txt
parent1168d5a85d2e9bf4b74926b1790ded87fd4d5072 (diff)
downloadCMake-499cef0367b1d578082084fa70e6a6c54ddb0d7a.zip
CMake-499cef0367b1d578082084fa70e6a6c54ddb0d7a.tar.gz
CMake-499cef0367b1d578082084fa70e6a6c54ddb0d7a.tar.bz2
now needs dynlib support
Diffstat (limited to 'Tests/Complex/Executable/CMakeLists.txt')
-rw-r--r--Tests/Complex/Executable/CMakeLists.txt6
1 files changed, 5 insertions, 1 deletions
diff --git a/Tests/Complex/Executable/CMakeLists.txt b/Tests/Complex/Executable/CMakeLists.txt
index 886b91f..9eaf3ff 100644
--- a/Tests/Complex/Executable/CMakeLists.txt
+++ b/Tests/Complex/Executable/CMakeLists.txt
@@ -13,7 +13,11 @@ LINK_LIBRARIES(${COMPLEX_LIBS})
ADD_EXECUTABLE(complex complex)
-TARGET_LINK_LIBRARIES(complex CMakeLib)
+IF (UNIX)
+ TARGET_LINK_LIBRARIES(complex CMakeLib ${CMAKE_DL_LIBS})
+ELSE(UNIX)
+ TARGET_LINK_LIBRARIES(complex CMakeLib)
+ENDIF (UNIX)
#
# Output the files required by 'complex' to a file.