summaryrefslogtreecommitdiffstats
path: root/Tests/ComplexOneConfig/CMakeLists.txt
diff options
context:
space:
mode:
authorKen Martin <ken.martin@kitware.com>2005-06-30 17:39:38 (GMT)
committerKen Martin <ken.martin@kitware.com>2005-06-30 17:39:38 (GMT)
commitba3b7c1588abf9009895e47a93a0614bec484315 (patch)
treeb15e17d83a19b6752ba34a18fd4a3e8e08ee8de0 /Tests/ComplexOneConfig/CMakeLists.txt
parent8ea0a1a2373f76cb78a0890932f115aad0fb8df5 (diff)
downloadCMake-ba3b7c1588abf9009895e47a93a0614bec484315.zip
CMake-ba3b7c1588abf9009895e47a93a0614bec484315.tar.gz
CMake-ba3b7c1588abf9009895e47a93a0614bec484315.tar.bz2
ENH: added testing of the WHILE command
Diffstat (limited to 'Tests/ComplexOneConfig/CMakeLists.txt')
-rw-r--r--Tests/ComplexOneConfig/CMakeLists.txt5
1 files changed, 5 insertions, 0 deletions
diff --git a/Tests/ComplexOneConfig/CMakeLists.txt b/Tests/ComplexOneConfig/CMakeLists.txt
index ca186bb..35f8ef2 100644
--- a/Tests/ComplexOneConfig/CMakeLists.txt
+++ b/Tests/ComplexOneConfig/CMakeLists.txt
@@ -237,6 +237,11 @@ FOREACH(x "a")
ENDIF(${x} MATCHES "a")
ENDFOREACH(x)
+# test WHILE command
+SET (while_var 1)
+WHILE (while_var LESS 1000)
+ SET(while_var ${while_var}0)
+ENDWHILE(while_var LESS 1000)
#
# Configure file