summaryrefslogtreecommitdiffstats
path: root/Tests/ComplexOneConfig/CMakeLists.txt
diff options
context:
space:
mode:
authorKen Martin <ken.martin@kitware.com>2008-06-26 17:01:35 (GMT)
committerKen Martin <ken.martin@kitware.com>2008-06-26 17:01:35 (GMT)
commit19e891532a915d1fa4fcf4cdba6254d28c2adc6c (patch)
tree8f128805f9f8e6bcef1bee2a10acf9e4b6e4bc83 /Tests/ComplexOneConfig/CMakeLists.txt
parentd8e05b43a1fc0370aa3ac84f4209b1b942809b89 (diff)
downloadCMake-19e891532a915d1fa4fcf4cdba6254d28c2adc6c.zip
CMake-19e891532a915d1fa4fcf4cdba6254d28c2adc6c.tar.gz
CMake-19e891532a915d1fa4fcf4cdba6254d28c2adc6c.tar.bz2
ENH: support parenthesis as arguments and in conditionals feature request #6191
Diffstat (limited to 'Tests/ComplexOneConfig/CMakeLists.txt')
-rw-r--r--Tests/ComplexOneConfig/CMakeLists.txt6
1 files changed, 6 insertions, 0 deletions
diff --git a/Tests/ComplexOneConfig/CMakeLists.txt b/Tests/ComplexOneConfig/CMakeLists.txt
index 1814528..c3f94b7 100644
--- a/Tests/ComplexOneConfig/CMakeLists.txt
+++ b/Tests/ComplexOneConfig/CMakeLists.txt
@@ -336,6 +336,12 @@ if (NOT ELSEIF_RESULT EQUAL 2)
set (ELSEIF_RESULT 0)
endif (NOT ELSEIF_RESULT EQUAL 2)
+# test handling of parenthetical groups in conditionals
+if (2 GREATER 1 AND (4 LESS 3 OR 5 LESS 6) AND NOT (7 GREATER 8))
+ set(CONDITIONAL_PARENTHESES 1)
+endif()
+
+
#
# Configure file
# (plug vars to #define so that they can be tested)