summaryrefslogtreecommitdiffstats
path: root/Tests/ComplexOneConfig/CMakeLists.txt
diff options
context:
space:
mode:
authorBrad King <brad.king@kitware.com>2008-03-20 22:25:59 (GMT)
committerBrad King <brad.king@kitware.com>2008-03-20 22:25:59 (GMT)
commita6a673979dded1cc97a76c193e29bab64b00480e (patch)
treebf8c8d7b6260059a997d0f49c8ce07f730a00682 /Tests/ComplexOneConfig/CMakeLists.txt
parent8e2f45c24b98ad97be584c61528a82807ef5cebe (diff)
downloadCMake-a6a673979dded1cc97a76c193e29bab64b00480e.zip
CMake-a6a673979dded1cc97a76c193e29bab64b00480e.tar.gz
CMake-a6a673979dded1cc97a76c193e29bab64b00480e.tar.bz2
ENH: Add "if(POLICY policy-id)" option for IF command.
- This will help projects support multiple CMake versions. - In order to set a policy when using a newer CMake but still working with an older CMake one may write if(POLICY CMP1234) cmake_policy(SET CMP1234 NEW) endif(POLICY CMP1234) - Note that since CMake 2.4 does not have if(POLICY) supporting it will also require using "if(COMMAND cmake_policy)"
Diffstat (limited to 'Tests/ComplexOneConfig/CMakeLists.txt')
-rw-r--r--Tests/ComplexOneConfig/CMakeLists.txt5
1 files changed, 5 insertions, 0 deletions
diff --git a/Tests/ComplexOneConfig/CMakeLists.txt b/Tests/ComplexOneConfig/CMakeLists.txt
index 5c67094..1814528 100644
--- a/Tests/ComplexOneConfig/CMakeLists.txt
+++ b/Tests/ComplexOneConfig/CMakeLists.txt
@@ -4,6 +4,11 @@
SET(CMAKE_BACKWARDS_COMPATIBILITY 1.4)
PROJECT (Complex)
+# Try setting a new policy. The IF test is for coverage.
+IF(POLICY CMP0003)
+ CMAKE_POLICY(SET CMP0003 NEW)
+ENDIF(POLICY CMP0003)
+
# Choose whether to test CMakeLib.
SET(COMPLEX_TEST_CMAKELIB 1)
IF(CMAKE_TEST_DIFFERENT_GENERATOR)