summaryrefslogtreecommitdiffstats
path: root/Tests/ComplexOneConfig/CMakeLists.txt
diff options
context:
space:
mode:
authorBill Hoffman <bill.hoffman@kitware.com>2001-08-23 17:57:45 (GMT)
committerBill Hoffman <bill.hoffman@kitware.com>2001-08-23 17:57:45 (GMT)
commit3a3b55679b1c28ac4d7c24c2de2ce28d88a3d21c (patch)
tree7bb6b35243fdc96afa879e06c1f4557ee22318b9 /Tests/ComplexOneConfig/CMakeLists.txt
parentbd4c5cf3625bc4d23f2f5c20fee7fa0bb34aed4b (diff)
downloadCMake-3a3b55679b1c28ac4d7c24c2de2ce28d88a3d21c.zip
CMake-3a3b55679b1c28ac4d7c24c2de2ce28d88a3d21c.tar.gz
CMake-3a3b55679b1c28ac4d7c24c2de2ce28d88a3d21c.tar.bz2
ENH: try to get better test coverage
Diffstat (limited to 'Tests/ComplexOneConfig/CMakeLists.txt')
-rw-r--r--Tests/ComplexOneConfig/CMakeLists.txt26
1 files changed, 26 insertions, 0 deletions
diff --git a/Tests/ComplexOneConfig/CMakeLists.txt b/Tests/ComplexOneConfig/CMakeLists.txt
new file mode 100644
index 0000000..c11a47b
--- /dev/null
+++ b/Tests/ComplexOneConfig/CMakeLists.txt
@@ -0,0 +1,26 @@
+# a simple test case
+PROJECT (Complex)
+
+ADD_DEFINITIONS(-DCMAKE_IS_FUN)
+SUBDIRS(Library Executable)
+SUBDIR_DEPENDS(Executable Library)
+
+INCLUDE(${Complex_SOURCE_DIR}/VarTests.txt)
+
+CONFIGURE_FILE(
+${Complex_SOURCE_DIR}/cmTestConfigure.h.in
+${Complex_BINARY_DIR}/cmTestConfigure.h)
+
+INCLUDE_DIRECTORIES(
+${Complex_BINARY_DIR}
+${Complex_SOURCE_DIR}/Library
+${Complex_SOURCE_DIR}/../../Source
+)
+LINK_DIRECTORIES(
+${Complex_BINARY_DIR}/Library
+)
+
+INCLUDE_REGULAR_EXPRESSION("^(cmTest|file|sharedFile).*$")
+
+SET (LIBRARY_OUTPUT_PATH ${Complex_BINARY_DIR}/bin/ CACHE PATH "Single output directory for building all libraries.")
+SET (EXECUTABLE_OUTPUT_PATH ${Complex_BINARY_DIR}/bin/ CACHE PATH "Single output directory for building all executables.")