summaryrefslogtreecommitdiffstats
path: root/Tests/ComplexOneConfig/CMakeLists.txt
diff options
context:
space:
mode:
authorBen Boeckel <ben.boeckel@kitware.com>2014-06-05 16:42:13 (GMT)
committerBen Boeckel <ben.boeckel@kitware.com>2014-06-05 16:42:13 (GMT)
commit7db77a828a3c79c5dce476b78e759478756ca091 (patch)
treec2d764a7457116ee2f137d34e2a2f83e8a65fdb9 /Tests/ComplexOneConfig/CMakeLists.txt
parent88818b680549651b6531a6648396d749b759afb2 (diff)
downloadCMake-7db77a828a3c79c5dce476b78e759478756ca091.zip
CMake-7db77a828a3c79c5dce476b78e759478756ca091.tar.gz
CMake-7db77a828a3c79c5dce476b78e759478756ca091.tar.bz2
tests: allow RelWithDebInfo and MinSizeRel configs to work
Diffstat (limited to 'Tests/ComplexOneConfig/CMakeLists.txt')
-rw-r--r--Tests/ComplexOneConfig/CMakeLists.txt8
1 files changed, 8 insertions, 0 deletions
diff --git a/Tests/ComplexOneConfig/CMakeLists.txt b/Tests/ComplexOneConfig/CMakeLists.txt
index d3d9132..3f17dcc 100644
--- a/Tests/ComplexOneConfig/CMakeLists.txt
+++ b/Tests/ComplexOneConfig/CMakeLists.txt
@@ -83,6 +83,14 @@ set_property(DIRECTORY
PROPERTY COMPILE_DEFINITIONS_RELEASE
CMAKE_IS_FUN_IN_RELEASE_MODE
)
+set_property(DIRECTORY
+ PROPERTY COMPILE_DEFINITIONS_RELWITHDEBINFO
+ CMAKE_IS_FUN_IN_RELEASE_MODE
+ )
+set_property(DIRECTORY
+ PROPERTY COMPILE_DEFINITIONS_MINSIZEREL
+ CMAKE_IS_FUN_IN_RELEASE_MODE
+ )
set(TEST_SEP "a b c")
separate_arguments(TEST_SEP)