summaryrefslogtreecommitdiffstats
path: root/Tests/ComplexOneConfig/CMakeLists.txt
diff options
context:
space:
mode:
authorSylvain Joubert <joubert.sy@gmail.com>2017-07-04 10:00:02 (GMT)
committerSylvain Joubert <joubert.sy@gmail.com>2017-07-04 10:00:02 (GMT)
commit58f47448210bf3fd3121bf91f74eb893ba9d034c (patch)
tree9b4a81430dda42f630fb03351332b4551aafde24 /Tests/ComplexOneConfig/CMakeLists.txt
parent74112c8da16ea5f2a4940d196d178da684626f92 (diff)
downloadCMake-58f47448210bf3fd3121bf91f74eb893ba9d034c.zip
CMake-58f47448210bf3fd3121bf91f74eb893ba9d034c.tar.gz
CMake-58f47448210bf3fd3121bf91f74eb893ba9d034c.tar.bz2
configure_file: Add support for indented cmakedefine
Optional spaces and/or tabs are now understood between the '#' character and the 'cmakedefine'/'cmakedefine01' words. This indentation is preserved in the output lines. Fixes: #13037
Diffstat (limited to 'Tests/ComplexOneConfig/CMakeLists.txt')
-rw-r--r--Tests/ComplexOneConfig/CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/Tests/ComplexOneConfig/CMakeLists.txt b/Tests/ComplexOneConfig/CMakeLists.txt
index 1b833b2..4cd0bae 100644
--- a/Tests/ComplexOneConfig/CMakeLists.txt
+++ b/Tests/ComplexOneConfig/CMakeLists.txt
@@ -313,6 +313,8 @@ endwhile()
set(SHOULD_BE_ZERO )
set(SHOULD_BE_ONE 1)
+set(SHOULD_BE_ZERO_AND_INDENTED )
+set(SHOULD_BE_ONE_AND_INDENTED 1)
# test elseif functionality, the mess below tries to catch problem
# of clauses being executed early or late etc