summaryrefslogtreecommitdiffstats
path: root/Tests/ComplexOneConfig/Executable/CMakeLists.txt
diff options
context:
space:
mode:
authorSebastien Barre <sebastien.barre@kitware.com>2002-01-20 06:58:57 (GMT)
committerSebastien Barre <sebastien.barre@kitware.com>2002-01-20 06:58:57 (GMT)
commit6f3570656caf463addeb9edafcecba33f0efcbb9 (patch)
treed7c00a97f0216851a1adc583ec0ed737b3e99e8e /Tests/ComplexOneConfig/Executable/CMakeLists.txt
parentf04128ad63b560079ab49118b9e64e2fe73ba39b (diff)
downloadCMake-6f3570656caf463addeb9edafcecba33f0efcbb9.zip
CMake-6f3570656caf463addeb9edafcecba33f0efcbb9.tar.gz
CMake-6f3570656caf463addeb9edafcecba33f0efcbb9.tar.bz2
Increase Coverage.
Diffstat (limited to 'Tests/ComplexOneConfig/Executable/CMakeLists.txt')
-rw-r--r--Tests/ComplexOneConfig/Executable/CMakeLists.txt6
1 files changed, 5 insertions, 1 deletions
diff --git a/Tests/ComplexOneConfig/Executable/CMakeLists.txt b/Tests/ComplexOneConfig/Executable/CMakeLists.txt
index 33332eb..438808f 100644
--- a/Tests/ComplexOneConfig/Executable/CMakeLists.txt
+++ b/Tests/ComplexOneConfig/Executable/CMakeLists.txt
@@ -17,7 +17,11 @@ FIND_LIBRARY(CMAKE_LIB
${Complex_BINARY_DIR}/../../Source/MinSizeRel
${Complex_BINARY_DIR}/../../Source/RelWithDebInfo)
-TARGET_LINK_LIBRARIES(complex ${CMAKE_LIB})
+# Specify the same one for debug/optimized to increase coverage
+TARGET_LINK_LIBRARIES(complex
+ ${CMAKE_LIB}
+ debug ${CMAKE_LIB}
+ optimized ${CMAKE_LIB})
#
# Output the files required by 'complex' to a file.