summaryrefslogtreecommitdiffstats
path: root/Tests/ComplexOneConfig/Executable/CMakeLists.txt
diff options
context:
space:
mode:
authorDavid Cole <david.cole@kitware.com>2012-01-09 19:09:11 (GMT)
committerCMake Topic Stage <kwrobot@kitware.com>2012-01-09 19:09:11 (GMT)
commitbe358c68c351ff6913fa11e2af96b7f6741cde1a (patch)
tree7b706c4b6b12d8382e84e8e611980027837138b5 /Tests/ComplexOneConfig/Executable/CMakeLists.txt
parent4fa5a7c845305cc23e184f1cc644af27475bcf04 (diff)
parent53d31c2426835d372f3286d134c90b5f6cc79441 (diff)
downloadCMake-be358c68c351ff6913fa11e2af96b7f6741cde1a.zip
CMake-be358c68c351ff6913fa11e2af96b7f6741cde1a.tar.gz
CMake-be358c68c351ff6913fa11e2af96b7f6741cde1a.tar.bz2
Merge topic 'test-Complex-cleanup'
53d31c2 complex: Remove unused option to test CMakeLib c1789e6 complex: Remove test dependence on cmSystemTools 569cee1 complex: Move cmSystemTools::UpperCase test to CMakeLibTests 49d6dd6 complex: Simplify test for single-character exe name 76ac88b complex: Move GeneratedFileStream test to CMakeLibTests 137e597 complex: Remove dynamic loader tests 6337920 complex: Sync Tests/ComplexOneConfig with Tests/Complex 6a75821 complex: Remove ancient unused ComplexRelativePaths test
Diffstat (limited to 'Tests/ComplexOneConfig/Executable/CMakeLists.txt')
-rw-r--r--Tests/ComplexOneConfig/Executable/CMakeLists.txt35
1 files changed, 11 insertions, 24 deletions
diff --git a/Tests/ComplexOneConfig/Executable/CMakeLists.txt b/Tests/ComplexOneConfig/Executable/CMakeLists.txt
index 98b29bb..3458362 100644
--- a/Tests/ComplexOneConfig/Executable/CMakeLists.txt
+++ b/Tests/ComplexOneConfig/Executable/CMakeLists.txt
@@ -5,25 +5,6 @@ CMAKE_MINIMUM_REQUIRED(VERSION 1.3)
SET(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -DTEST_CXX_FLAGS")
SET(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -DTEST_C_FLAGS")
-IF(COMPLEX_TEST_CMAKELIB)
- # Link to CMake lib
- LINK_DIRECTORIES(${Complex_BINARY_DIR}/../../Source)
- LINK_DIRECTORIES(${Complex_BINARY_DIR}/../../Source/kwsys)
- LINK_DIRECTORIES(${Complex_BINARY_DIR}/../../Utilities/cmexpat)
- LINK_DIRECTORIES(${Complex_BINARY_DIR}/../../Utilities/cmzlib)
- # prefer the new curl if it is around
- IF(EXISTS ${Complex_BINARY_DIR}/../../Utilities/cmcurl-7.19.0)
- LINK_DIRECTORIES(${Complex_BINARY_DIR}/../../Utilities/cmcurl-7.19.0/lib)
- ENDIF(EXISTS ${Complex_BINARY_DIR}/../../Utilities/cmcurl-7.19.0)
- IF(EXISTS ${Complex_BINARY_DIR}/../../Utilities/cmcurl)
- LINK_DIRECTORIES(${Complex_BINARY_DIR}/../../Utilities/cmcurl)
- ENDIF(EXISTS ${Complex_BINARY_DIR}/../../Utilities/cmcurl)
- LINK_DIRECTORIES(
- ${Complex_BINARY_DIR}/../../Utilities/cmlibarchive/libarchive
- ${Complex_BINARY_DIR}/../../Utilities/cmbzip2
- )
-ENDIF(COMPLEX_TEST_CMAKELIB)
-
# Create an imported target for if(TARGET) test below.
ADD_LIBRARY(ExeImportedTarget UNKNOWN IMPORTED)
@@ -49,13 +30,19 @@ LINK_LIBRARIES(${COMPLEX_LIBS})
SET_SOURCE_FILES_PROPERTIES(complex_nobuild.cxx PROPERTIES
HEADER_FILE_ONLY 1)
+# Test forcing a .c file to not build.
+# This makes sure a mixed language library is created
+# with header file only sources
+SET_SOURCE_FILES_PROPERTIES(complex_nobuild.c PROPERTIES
+ HEADER_FILE_ONLY 1)
+
+INCLUDE_DIRECTORIES(${CMAKE_CURRENT_BINARY_DIR})
ADD_EXECUTABLE(A A.cxx A.hh A.h A.txt)
-ADD_EXECUTABLE(complex complex testcflags.c )
+ADD_CUSTOM_COMMAND(OUTPUT Aout.h COMMAND A > Aout.h VERBATIM)
+ADD_EXECUTABLE(complex complex testcflags.c Aout.h)
# Sub1/NameConflictTest.c Sub2/NameConflictTest.c)
-ADD_EXECUTABLE(complex.file complex.file.cxx complex_nobuild.cxx)
-IF(COMPLEX_TEST_CMAKELIB)
- TARGET_LINK_LIBRARIES(complex CMakeLib cmsys cmexpat cmzlib cmlibarchive cmbzip2 cmcurl)
-ENDIF(COMPLEX_TEST_CMAKELIB)
+ADD_EXECUTABLE(complex.file complex.file.cxx complex_nobuild.cxx
+ complex_nobuild.c)
IF (UNIX)
TARGET_LINK_LIBRARIES(complex ${CMAKE_DL_LIBS})