summaryrefslogtreecommitdiffstats
path: root/Tests/ComplexOneConfig/Executable/CMakeLists.txt
diff options
context:
space:
mode:
authorSebastien Barre <sebastien.barre@kitware.com>2002-01-20 02:24:55 (GMT)
committerSebastien Barre <sebastien.barre@kitware.com>2002-01-20 02:24:55 (GMT)
commitc8d8e693cf24d657ced601c8173258f89b62e71a (patch)
tree2fcf0b3929d709ec76fced03145ce59897a8c04d /Tests/ComplexOneConfig/Executable/CMakeLists.txt
parent30b3cc0755b43bf3ad04cf2fa4d5af441cbadfd7 (diff)
downloadCMake-c8d8e693cf24d657ced601c8173258f89b62e71a.zip
CMake-c8d8e693cf24d657ced601c8173258f89b62e71a.tar.gz
CMake-c8d8e693cf24d657ced601c8173258f89b62e71a.tar.bz2
Add documentation, comments. Move some 'Complex' sub-tests into 2 new 'Wrapping' and 'Testing' tests.
Diffstat (limited to 'Tests/ComplexOneConfig/Executable/CMakeLists.txt')
-rw-r--r--Tests/ComplexOneConfig/Executable/CMakeLists.txt16
1 files changed, 9 insertions, 7 deletions
diff --git a/Tests/ComplexOneConfig/Executable/CMakeLists.txt b/Tests/ComplexOneConfig/Executable/CMakeLists.txt
index 15808b4..26d3df5 100644
--- a/Tests/ComplexOneConfig/Executable/CMakeLists.txt
+++ b/Tests/ComplexOneConfig/Executable/CMakeLists.txt
@@ -1,8 +1,14 @@
+#
+# Create exe.
+#
ADD_EXECUTABLE(complex complex)
TARGET_LINK_LIBRARIES(complex CMakeTestLibrary)
TARGET_LINK_LIBRARIES(complex CMakeTestLibraryShared)
+#
+# Link to CMake lib
+#
FIND_LIBRARY(CMAKE_LIB
CMakeLib
${Complex_BINARY_DIR}/../../Source
@@ -12,15 +18,11 @@ FIND_LIBRARY(CMAKE_LIB
${Complex_BINARY_DIR}/../../Source/RelWithDebInfo)
TARGET_LINK_LIBRARIES(complex ${CMAKE_LIB})
-LINK_LIBRARIES(${CMAKE_LIB})
#
-# Testing
-#
-ADD_TEST(complex ${Complex_BINARY_DIR}/bin/complex)
-
-#
-# More coverage
+# Extra coverage.Not used.
#
INSTALL_TARGETS(/tmp complex)
INSTALL_PROGRAMS(/tmp complex)
+
+SOURCE_GROUP(A_GROUP ".cxx")