summaryrefslogtreecommitdiffstats
path: root/Tests/ComplexOneConfig/Executable/CMakeLists.txt
diff options
context:
space:
mode:
authorBrad King <brad.king@kitware.com>2011-12-23 20:55:34 (GMT)
committerBrad King <brad.king@kitware.com>2011-12-23 21:16:57 (GMT)
commit53d31c2426835d372f3286d134c90b5f6cc79441 (patch)
tree5ff4ccd64626c377f2dd7288777789ffa11fbb3a /Tests/ComplexOneConfig/Executable/CMakeLists.txt
parentc1789e69869370889bbe57f2ec8606ba45ab5034 (diff)
downloadCMake-53d31c2426835d372f3286d134c90b5f6cc79441.zip
CMake-53d31c2426835d372f3286d134c90b5f6cc79441.tar.gz
CMake-53d31c2426835d372f3286d134c90b5f6cc79441.tar.bz2
complex: Remove unused option to test CMakeLib
Now that the Complex tests do not depend on cmSystemTools or other classes from CMakeLib the COMPLEX_TEST_CMAKELIB option is useless.
Diffstat (limited to 'Tests/ComplexOneConfig/Executable/CMakeLists.txt')
-rw-r--r--Tests/ComplexOneConfig/Executable/CMakeLists.txt22
1 files changed, 0 insertions, 22 deletions
diff --git a/Tests/ComplexOneConfig/Executable/CMakeLists.txt b/Tests/ComplexOneConfig/Executable/CMakeLists.txt
index c76944f..3458362 100644
--- a/Tests/ComplexOneConfig/Executable/CMakeLists.txt
+++ b/Tests/ComplexOneConfig/Executable/CMakeLists.txt
@@ -5,25 +5,6 @@ CMAKE_MINIMUM_REQUIRED(VERSION 1.3)
SET(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -DTEST_CXX_FLAGS")
SET(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -DTEST_C_FLAGS")
-IF(COMPLEX_TEST_CMAKELIB)
- # Link to CMake lib
- LINK_DIRECTORIES(${Complex_BINARY_DIR}/../../Source)
- LINK_DIRECTORIES(${Complex_BINARY_DIR}/../../Source/kwsys)
- LINK_DIRECTORIES(${Complex_BINARY_DIR}/../../Utilities/cmexpat)
- LINK_DIRECTORIES(${Complex_BINARY_DIR}/../../Utilities/cmzlib)
- # prefer the new curl if it is around
- IF(EXISTS ${Complex_BINARY_DIR}/../../Utilities/cmcurl-7.19.0)
- LINK_DIRECTORIES(${Complex_BINARY_DIR}/../../Utilities/cmcurl-7.19.0/lib)
- ENDIF(EXISTS ${Complex_BINARY_DIR}/../../Utilities/cmcurl-7.19.0)
- IF(EXISTS ${Complex_BINARY_DIR}/../../Utilities/cmcurl)
- LINK_DIRECTORIES(${Complex_BINARY_DIR}/../../Utilities/cmcurl)
- ENDIF(EXISTS ${Complex_BINARY_DIR}/../../Utilities/cmcurl)
- LINK_DIRECTORIES(
- ${Complex_BINARY_DIR}/../../Utilities/cmlibarchive/libarchive
- ${Complex_BINARY_DIR}/../../Utilities/cmbzip2
- )
-ENDIF(COMPLEX_TEST_CMAKELIB)
-
# Create an imported target for if(TARGET) test below.
ADD_LIBRARY(ExeImportedTarget UNKNOWN IMPORTED)
@@ -62,9 +43,6 @@ ADD_EXECUTABLE(complex complex testcflags.c Aout.h)
# Sub1/NameConflictTest.c Sub2/NameConflictTest.c)
ADD_EXECUTABLE(complex.file complex.file.cxx complex_nobuild.cxx
complex_nobuild.c)
-IF(COMPLEX_TEST_CMAKELIB)
- TARGET_LINK_LIBRARIES(complex CMakeLib cmsys cmlibarchive cmcurl cmexpat cmzlib cmbzip2)
-ENDIF(COMPLEX_TEST_CMAKELIB)
IF (UNIX)
TARGET_LINK_LIBRARIES(complex ${CMAKE_DL_LIBS})