summaryrefslogtreecommitdiffstats
path: root/Tests/ComplexOneConfig/Executable/CMakeLists.txt
diff options
context:
space:
mode:
authorBrad King <brad.king@kitware.com>2006-05-23 16:51:26 (GMT)
committerBrad King <brad.king@kitware.com>2006-05-23 16:51:26 (GMT)
commit9a74185695ef8312310576d6716d1626ed75a944 (patch)
tree03dc7bdabc81328d4028c1db3ada4f8a49f25ac9 /Tests/ComplexOneConfig/Executable/CMakeLists.txt
parent13a68cd97888d451d9f40b61891709af1648432b (diff)
downloadCMake-9a74185695ef8312310576d6716d1626ed75a944.zip
CMake-9a74185695ef8312310576d6716d1626ed75a944.tar.gz
CMake-9a74185695ef8312310576d6716d1626ed75a944.tar.bz2
BUG: Fix REMOVE_DEFINITIONS command to not remove substrings.
Diffstat (limited to 'Tests/ComplexOneConfig/Executable/CMakeLists.txt')
-rw-r--r--Tests/ComplexOneConfig/Executable/CMakeLists.txt8
1 files changed, 8 insertions, 0 deletions
diff --git a/Tests/ComplexOneConfig/Executable/CMakeLists.txt b/Tests/ComplexOneConfig/Executable/CMakeLists.txt
index 6a217f0..dae5775 100644
--- a/Tests/ComplexOneConfig/Executable/CMakeLists.txt
+++ b/Tests/ComplexOneConfig/Executable/CMakeLists.txt
@@ -55,6 +55,14 @@ IF ("${LF_VALUE}" STREQUAL "${CMAKE_CURRENT_SOURCE_DIR}/CMakeLists.txt;${CMAKE_C
ADD_DEFINITIONS(-DCMAKE_FOUND_LISTFILE_STACK)
ENDIF ("${LF_VALUE}" STREQUAL "${CMAKE_CURRENT_SOURCE_DIR}/CMakeLists.txt;${CMAKE_CURRENT_SOURCE_DIR}/Included.cmake")
+# Test add/remove definitions.
+ADD_DEFINITIONS(
+ -DCOMPLEX_DEFINED_PRE
+ -DCOMPLEX_DEFINED
+ -DCOMPLEX_DEFINED_POST
+ -DCOMPLEX_DEFINED
+ )
+REMOVE_DEFINITIONS(-DCOMPLEX_DEFINED)
# Test pre-build/pre-link/post-build rules for an executable.
ADD_CUSTOM_COMMAND(TARGET complex PRE_BUILD