summaryrefslogtreecommitdiffstats
path: root/Tests/ComplexOneConfig/Executable/CMakeLists.txt
diff options
context:
space:
mode:
authorBrad King <brad.king@kitware.com>2011-12-23 20:08:47 (GMT)
committerBrad King <brad.king@kitware.com>2011-12-23 21:16:50 (GMT)
commit76ac88b730f32dcdef80216766b3eaecb6257ed6 (patch)
treef6a6c395855c0339a0666becb4aa692ae46d0fad /Tests/ComplexOneConfig/Executable/CMakeLists.txt
parent137e5974bcde960cf408eb4027d35defa9a93217 (diff)
downloadCMake-76ac88b730f32dcdef80216766b3eaecb6257ed6.zip
CMake-76ac88b730f32dcdef80216766b3eaecb6257ed6.tar.gz
CMake-76ac88b730f32dcdef80216766b3eaecb6257ed6.tar.bz2
complex: Move GeneratedFileStream test to CMakeLibTests
This test belongs in the CMakeLibTests test driver executable which correctly links to CMakeLib. Fix incorrect library link order in the Complex tests exposed by this change.
Diffstat (limited to 'Tests/ComplexOneConfig/Executable/CMakeLists.txt')
-rw-r--r--Tests/ComplexOneConfig/Executable/CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/Tests/ComplexOneConfig/Executable/CMakeLists.txt b/Tests/ComplexOneConfig/Executable/CMakeLists.txt
index 08cc7d4..1f0b999 100644
--- a/Tests/ComplexOneConfig/Executable/CMakeLists.txt
+++ b/Tests/ComplexOneConfig/Executable/CMakeLists.txt
@@ -61,7 +61,7 @@ ADD_EXECUTABLE(complex complex testcflags.c )
ADD_EXECUTABLE(complex.file complex.file.cxx complex_nobuild.cxx
complex_nobuild.c)
IF(COMPLEX_TEST_CMAKELIB)
- TARGET_LINK_LIBRARIES(complex CMakeLib cmsys cmexpat cmzlib cmlibarchive cmbzip2 cmcurl)
+ TARGET_LINK_LIBRARIES(complex CMakeLib cmsys cmlibarchive cmcurl cmexpat cmzlib cmbzip2)
ENDIF(COMPLEX_TEST_CMAKELIB)
IF (UNIX)