summaryrefslogtreecommitdiffstats
path: root/Tests/ComplexOneConfig/Library/CMakeLists.txt
diff options
context:
space:
mode:
authorBill Hoffman <bill.hoffman@kitware.com>2003-01-15 22:31:22 (GMT)
committerBill Hoffman <bill.hoffman@kitware.com>2003-01-15 22:31:22 (GMT)
commitc6d2312619f008a691d9a313988b15c02e4f94cd (patch)
tree3dfde773b647d2739f97f0217dd1a40225f1c0ff /Tests/ComplexOneConfig/Library/CMakeLists.txt
parent17d8775e82aafe373f25b6d6ce9a568ab78816f2 (diff)
downloadCMake-c6d2312619f008a691d9a313988b15c02e4f94cd.zip
CMake-c6d2312619f008a691d9a313988b15c02e4f94cd.tar.gz
CMake-c6d2312619f008a691d9a313988b15c02e4f94cd.tar.bz2
ENH: add testing for modules and one two config modes for cmaketest
Diffstat (limited to 'Tests/ComplexOneConfig/Library/CMakeLists.txt')
-rw-r--r--Tests/ComplexOneConfig/Library/CMakeLists.txt3
1 files changed, 2 insertions, 1 deletions
diff --git a/Tests/ComplexOneConfig/Library/CMakeLists.txt b/Tests/ComplexOneConfig/Library/CMakeLists.txt
index 9fccfc5..0df970b 100644
--- a/Tests/ComplexOneConfig/Library/CMakeLists.txt
+++ b/Tests/ComplexOneConfig/Library/CMakeLists.txt
@@ -38,6 +38,7 @@ ENDIF(WIN32)
#
SOURCE_FILES(SharedLibrarySources sharedFile)
ADD_LIBRARY(CMakeTestLibraryShared SHARED ${SharedLibrarySources})
+ADD_LIBRARY(CMakeTestModule MODULE moduleFile.c)
SET(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -DTEST_C_FLAGS")
ADD_LIBRARY(CMakeTestCLibraryShared SHARED testConly.c)
SET_TARGET_PROPERTIES(CMakeTestCLibraryShared PROPERTIES FOO BAR)
@@ -55,7 +56,7 @@ ENDIF(${FOO_BAR_VAR} MATCHES "BAR")
# The 'complex' executable will then test if this file exists and remove it.
#
ADD_DEPENDENCIES(CMakeTestLibraryShared create_file)
-
+MESSAGE("complex bin dir is ${Complex_BINARY_DIR}")
ADD_CUSTOM_COMMAND(COMMAND ${CREATE_FILE_EXE}
ARGS "${Complex_BINARY_DIR}/Library/postbuild.txt"
TARGET CMakeTestLibraryShared)