summaryrefslogtreecommitdiffstats
path: root/Tests/ComplexOneConfig/Library/CMakeLists.txt
diff options
context:
space:
mode:
authorDaniel Pfeifer <daniel@pfeifer-mail.de>2016-07-27 22:43:04 (GMT)
committerDaniel Pfeifer <daniel@pfeifer-mail.de>2016-07-27 22:43:04 (GMT)
commit7a649111cdea2b10f2ec57084416be619867fbfb (patch)
tree072e1343376835ba4dda7689db02dc51598e005b /Tests/ComplexOneConfig/Library/CMakeLists.txt
parent5d0d980d9949daf596e10715d686adc95c1c232b (diff)
downloadCMake-7a649111cdea2b10f2ec57084416be619867fbfb.zip
CMake-7a649111cdea2b10f2ec57084416be619867fbfb.tar.gz
CMake-7a649111cdea2b10f2ec57084416be619867fbfb.tar.bz2
Use string(APPEND) in Tests
Automate with: find Tests -type f -print0 | xargs -0 perl -i -0pe \ 's/set\(([a-zA-Z0-9_]+)(\s+)"\$\{\1\}([^"])/string(APPEND \1\2"\3/g'
Diffstat (limited to 'Tests/ComplexOneConfig/Library/CMakeLists.txt')
-rw-r--r--Tests/ComplexOneConfig/Library/CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/Tests/ComplexOneConfig/Library/CMakeLists.txt b/Tests/ComplexOneConfig/Library/CMakeLists.txt
index f00cbd6..dbf806e 100644
--- a/Tests/ComplexOneConfig/Library/CMakeLists.txt
+++ b/Tests/ComplexOneConfig/Library/CMakeLists.txt
@@ -43,7 +43,7 @@ endif()
#
set(SharedLibrarySources sharedFile)
add_library(CMakeTestLibraryShared SHARED ${SharedLibrarySources})
-set(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -DTEST_C_FLAGS")
+string(APPEND CMAKE_C_FLAGS " -DTEST_C_FLAGS")
add_library(CMakeTestCLibraryShared SHARED testConly.c)
define_property(
TARGET PROPERTY FOO