summaryrefslogtreecommitdiffstats
path: root/Tests/ComplexRelativePaths/CMakeLists.txt
diff options
context:
space:
mode:
authorBill Hoffman <bill.hoffman@kitware.com>2006-11-10 15:12:56 (GMT)
committerBill Hoffman <bill.hoffman@kitware.com>2006-11-10 15:12:56 (GMT)
commitc8c3bd7acd88455772f0301062856e0d9622db31 (patch)
treefdec66913bf2cccfe2ad889798cd337fb1b35ab7 /Tests/ComplexRelativePaths/CMakeLists.txt
parentda21bc79bb50059a658c9f7304852b5a307e92a1 (diff)
downloadCMake-c8c3bd7acd88455772f0301062856e0d9622db31.zip
CMake-c8c3bd7acd88455772f0301062856e0d9622db31.tar.gz
CMake-c8c3bd7acd88455772f0301062856e0d9622db31.tar.bz2
ENH: merge from main tree fix for vs all build qt and mpi2
Diffstat (limited to 'Tests/ComplexRelativePaths/CMakeLists.txt')
-rw-r--r--Tests/ComplexRelativePaths/CMakeLists.txt11
1 files changed, 11 insertions, 0 deletions
diff --git a/Tests/ComplexRelativePaths/CMakeLists.txt b/Tests/ComplexRelativePaths/CMakeLists.txt
index 5a28e56..deb0800 100644
--- a/Tests/ComplexRelativePaths/CMakeLists.txt
+++ b/Tests/ComplexRelativePaths/CMakeLists.txt
@@ -53,6 +53,17 @@ ENDMACRO(TEST_VAR_ARG)
TEST_VAR_ARG(1 2 3)
+# Floating-point comparison test.
+IF(2.4 LESS 2.4)
+ MESSAGE(FATAL_ERROR "Failed: 2.4 LESS 2.4")
+ENDIF(2.4 LESS 2.4)
+IF(2.4 GREATER 2.4)
+ MESSAGE(FATAL_ERROR "Failed: 2.4 GREATER 2.4")
+ENDIF(2.4 GREATER 2.4)
+IF(NOT 2.4 EQUAL 2.4)
+ MESSAGE(FATAL_ERROR "Failed: NOT 2.4 EQUAL 2.4")
+ENDIF(NOT 2.4 EQUAL 2.4)
+
#
# Use the ansi CXX compile flag for building cmake
#