summaryrefslogtreecommitdiffstats
path: root/Tests/ComplexRelativePaths/CMakeLists.txt
diff options
context:
space:
mode:
authorSebastien Barre <sebastien.barre@kitware.com>2002-01-19 00:21:43 (GMT)
committerSebastien Barre <sebastien.barre@kitware.com>2002-01-19 00:21:43 (GMT)
commitb6bdbc54fc5f02aa166323855e67b7c7f61fb56e (patch)
tree8fe09182485c9b6c2a3d367ccbb3b6cec4928d97 /Tests/ComplexRelativePaths/CMakeLists.txt
parent747457abb647910742c5e13529894950d3c9ada4 (diff)
downloadCMake-b6bdbc54fc5f02aa166323855e67b7c7f61fb56e.zip
CMake-b6bdbc54fc5f02aa166323855e67b7c7f61fb56e.tar.gz
CMake-b6bdbc54fc5f02aa166323855e67b7c7f61fb56e.tar.bz2
ENH: Increase test + coverage
Diffstat (limited to 'Tests/ComplexRelativePaths/CMakeLists.txt')
-rw-r--r--Tests/ComplexRelativePaths/CMakeLists.txt26
1 files changed, 25 insertions, 1 deletions
diff --git a/Tests/ComplexRelativePaths/CMakeLists.txt b/Tests/ComplexRelativePaths/CMakeLists.txt
index 10f270e..050cd3e 100644
--- a/Tests/ComplexRelativePaths/CMakeLists.txt
+++ b/Tests/ComplexRelativePaths/CMakeLists.txt
@@ -1,5 +1,5 @@
#
-# A simple test case
+# A more complex test case
#
PROJECT (Complex)
@@ -14,6 +14,8 @@ ADD_DEFINITIONS(-DCMAKE_IS_FUN)
INCLUDE(${Complex_SOURCE_DIR}/VarTests.txt)
+LOAD_CACHE(${Complex_SOURCE_DIR})
+
CONFIGURE_FILE(
${Complex_SOURCE_DIR}/cmTestConfigure.h.in
${Complex_BINARY_DIR}/cmTestConfigure.h)
@@ -59,3 +61,25 @@ IF (EXEC_PROGRAM)
EXEC_PROGRAM("echo EXEC_PROGRAM")
ENDIF (EXEC_PROGRAM)
+#
+# More coverage
+#
+ABSTRACT_FILES(
+ ExtraSources/file1.cxx
+)
+
+INSTALL_FILES(/tmp .h ${Complex_BINARY_DIR}/cmTestConfigure.h)
+
+#
+# Create directory.
+# The 'complex' executable will then test if this dir exists,
+# sadly it won't be able to remove it.
+#
+MAKE_DIRECTORY("${Complex_BINARY_DIR}/make_dir")
+
+#
+# Test Cable
+#
+CABLE_CLASS_SET(Float float)
+CABLE_CLASS_SET(Mesh "itk::Mesh<$Float>")
+