summaryrefslogtreecommitdiffstats
path: root/Tests/ComplexRelativePaths/CMakeLists.txt
diff options
context:
space:
mode:
authorSebastien Barre <sebastien.barre@kitware.com>2002-01-18 17:03:32 (GMT)
committerSebastien Barre <sebastien.barre@kitware.com>2002-01-18 17:03:32 (GMT)
commit914e051fd781b2f90e731e4bf967b5bcccc56962 (patch)
tree6543b6d67672291ecf91de40af8bf6742f52739f /Tests/ComplexRelativePaths/CMakeLists.txt
parent6d1a312c7b9fb89d1f3e1da992941fec2e4df7ac (diff)
downloadCMake-914e051fd781b2f90e731e4bf967b5bcccc56962.zip
CMake-914e051fd781b2f90e731e4bf967b5bcccc56962.tar.gz
CMake-914e051fd781b2f90e731e4bf967b5bcccc56962.tar.bz2
Increase coverage, add tests
Diffstat (limited to 'Tests/ComplexRelativePaths/CMakeLists.txt')
-rw-r--r--Tests/ComplexRelativePaths/CMakeLists.txt8
1 files changed, 8 insertions, 0 deletions
diff --git a/Tests/ComplexRelativePaths/CMakeLists.txt b/Tests/ComplexRelativePaths/CMakeLists.txt
index 51a5656..10f270e 100644
--- a/Tests/ComplexRelativePaths/CMakeLists.txt
+++ b/Tests/ComplexRelativePaths/CMakeLists.txt
@@ -50,4 +50,12 @@ ENDIF (EXECUTABLE_OUTPUT_PATH)
SUBDIRS(Library Executable)
SUBDIR_DEPENDS(Executable Library)
+#
+# Exec program
+# Increase coverage.
+#
+OPTION(EXEC_PROGRAM "Test EXEC_PROGRAM" ON)
+IF (EXEC_PROGRAM)
+ EXEC_PROGRAM("echo EXEC_PROGRAM")
+ENDIF (EXEC_PROGRAM)