summaryrefslogtreecommitdiffstats
path: root/Tests/ComplexRelativePaths/CMakeLists.txt
diff options
context:
space:
mode:
authorBill Hoffman <bill.hoffman@kitware.com>2002-05-23 17:04:00 (GMT)
committerBill Hoffman <bill.hoffman@kitware.com>2002-05-23 17:04:00 (GMT)
commit14b07c0973f367352a75550af864b56dc99c3848 (patch)
treec78524be265379c84c4b1658b6d89e737092ef42 /Tests/ComplexRelativePaths/CMakeLists.txt
parent11d100c94f055f70f478125dace67434a2d1832b (diff)
downloadCMake-14b07c0973f367352a75550af864b56dc99c3848.zip
CMake-14b07c0973f367352a75550af864b56dc99c3848.tar.gz
CMake-14b07c0973f367352a75550af864b56dc99c3848.tar.bz2
add a test for escape quotes and configure file
Diffstat (limited to 'Tests/ComplexRelativePaths/CMakeLists.txt')
-rw-r--r--Tests/ComplexRelativePaths/CMakeLists.txt6
1 files changed, 6 insertions, 0 deletions
diff --git a/Tests/ComplexRelativePaths/CMakeLists.txt b/Tests/ComplexRelativePaths/CMakeLists.txt
index 5cead76..bbf72a0 100644
--- a/Tests/ComplexRelativePaths/CMakeLists.txt
+++ b/Tests/ComplexRelativePaths/CMakeLists.txt
@@ -156,6 +156,12 @@ CONFIGURE_FILE(
${Complex_SOURCE_DIR}/cmTestConfigure.h.in
${Complex_BINARY_DIR}/cmTestConfigure.h)
+SET(STRING_WITH_QUOTES "\"hello world\"")
+# test CONFIGURE_FILE with ESCAPE_QUOTES on
+CONFIGURE_FILE(
+ ${Complex_SOURCE_DIR}/cmTestConfigureEscape.h.in
+ ${Complex_BINARY_DIR}/cmTestConfigureEscape.h ESCAPE_QUOTES)
+
#
# Create the libs and the main exe
#