summaryrefslogtreecommitdiffstats
path: root/Tests/ComplexRelativePaths/CMakeLists.txt
diff options
context:
space:
mode:
authorBill Hoffman <bill.hoffman@kitware.com>2002-08-22 21:06:05 (GMT)
committerBill Hoffman <bill.hoffman@kitware.com>2002-08-22 21:06:05 (GMT)
commit40cf734152304bd00a1c0895f4e37f0ff87ca43d (patch)
treed60103e601dca03157ae897e441bcc294c92d82c /Tests/ComplexRelativePaths/CMakeLists.txt
parentfaf4b68ca91b6bc068dce1f988a2a36d612c60f5 (diff)
downloadCMake-40cf734152304bd00a1c0895f4e37f0ff87ca43d.zip
CMake-40cf734152304bd00a1c0895f4e37f0ff87ca43d.tar.gz
CMake-40cf734152304bd00a1c0895f4e37f0ff87ca43d.tar.bz2
BUG: fix for borland and a shared CMakeLib
Diffstat (limited to 'Tests/ComplexRelativePaths/CMakeLists.txt')
-rw-r--r--Tests/ComplexRelativePaths/CMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/Tests/ComplexRelativePaths/CMakeLists.txt b/Tests/ComplexRelativePaths/CMakeLists.txt
index d9c7568..c119f14 100644
--- a/Tests/ComplexRelativePaths/CMakeLists.txt
+++ b/Tests/ComplexRelativePaths/CMakeLists.txt
@@ -3,6 +3,9 @@
#
PROJECT (Complex)
+# For borland since CMakeLib is a dll all .cxx files have
+# to be compiled with -tWR to get the dll version of the borland
+# standard library
IF(BORLAND)
SET(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -tWR")
SET(CMAKE_LINKER_FLAGS "${CMAKE_LINKER_FLAGS} -tWR")