summaryrefslogtreecommitdiffstats
path: root/Tests/ComplexRelativePaths/CMakeLists.txt
diff options
context:
space:
mode:
authorKen Martin <ken.martin@kitware.com>2002-08-26 19:20:47 (GMT)
committerKen Martin <ken.martin@kitware.com>2002-08-26 19:20:47 (GMT)
commitae6e90e872fc6ed97cc221713e833e21f5552e0b (patch)
treec3c9f4e14c47fb27a5ffb648802b40e9588f5180 /Tests/ComplexRelativePaths/CMakeLists.txt
parentd99454cba4dc5d2d1e51dc2cc5889cb32e468b6a (diff)
downloadCMake-ae6e90e872fc6ed97cc221713e833e21f5552e0b.zip
CMake-ae6e90e872fc6ed97cc221713e833e21f5552e0b.tar.gz
CMake-ae6e90e872fc6ed97cc221713e833e21f5552e0b.tar.bz2
added new form of Set source file properties command
Diffstat (limited to 'Tests/ComplexRelativePaths/CMakeLists.txt')
-rw-r--r--Tests/ComplexRelativePaths/CMakeLists.txt9
1 files changed, 9 insertions, 0 deletions
diff --git a/Tests/ComplexRelativePaths/CMakeLists.txt b/Tests/ComplexRelativePaths/CMakeLists.txt
index 4b05d07..06466da 100644
--- a/Tests/ComplexRelativePaths/CMakeLists.txt
+++ b/Tests/ComplexRelativePaths/CMakeLists.txt
@@ -140,6 +140,15 @@ GET_SOURCE_FILE_PROPERTY(FILE_HAS_ABSTRACT nonexisting_file2 ABSTRACT)
GET_SOURCE_FILE_PROPERTY(FILE_HAS_WRAP_EXCLUDE nonexisting_file2 WRAP_EXCLUDE)
GET_SOURCE_FILE_PROPERTY(FILE_COMPILE_FLAGS nonexisting_file2 COMPILE_FLAGS)
+SET_SOURCE_FILES_PROPERTIES(nonexisting_file3 PROPERTIES
+ GENERATED 1
+ ABSTRACT 1
+ WRAP_EXCLUDE 1
+ COMPILE_FLAGS "-foo -bar")
+GET_SOURCE_FILE_PROPERTY(FILE_HAS_ABSTRACT nonexisting_file3 ABSTRACT)
+GET_SOURCE_FILE_PROPERTY(FILE_HAS_WRAP_EXCLUDE nonexisting_file3 WRAP_EXCLUDE)
+GET_SOURCE_FILE_PROPERTY(FILE_COMPILE_FLAGS nonexisting_file3 COMPILE_FLAGS)
+
#
# Test registry (win32)
# Create a file, put its path in a registry key, try to find the file in that