summaryrefslogtreecommitdiffstats
path: root/Tests/ComplexRelativePaths/CMakeLists.txt
diff options
context:
space:
mode:
authorBrad King <brad.king@kitware.com>2006-10-19 18:45:41 (GMT)
committerBrad King <brad.king@kitware.com>2006-10-19 18:45:41 (GMT)
commitb646183f441bcc3c9f3b094defbe71a3b56a60a3 (patch)
tree78905f86d15d4997b587f368c3f069af1e6e60c5 /Tests/ComplexRelativePaths/CMakeLists.txt
parent93ce08e373c8ba7fa844fd3fa04f113e2c2a2d71 (diff)
downloadCMake-b646183f441bcc3c9f3b094defbe71a3b56a60a3.zip
CMake-b646183f441bcc3c9f3b094defbe71a3b56a60a3.tar.gz
CMake-b646183f441bcc3c9f3b094defbe71a3b56a60a3.tar.bz2
ENH: Added explicit name for option to test CMakeLib. Added option to disable testing of CMakeLib if system utility libraries are used until linking made easier.
Diffstat (limited to 'Tests/ComplexRelativePaths/CMakeLists.txt')
-rw-r--r--Tests/ComplexRelativePaths/CMakeLists.txt9
1 files changed, 9 insertions, 0 deletions
diff --git a/Tests/ComplexRelativePaths/CMakeLists.txt b/Tests/ComplexRelativePaths/CMakeLists.txt
index fa3ee41..5a28e56 100644
--- a/Tests/ComplexRelativePaths/CMakeLists.txt
+++ b/Tests/ComplexRelativePaths/CMakeLists.txt
@@ -4,6 +4,15 @@
SET(CMAKE_BACKWARDS_COMPATIBILITY 1.4)
PROJECT (Complex)
+# Choose whether to test CMakeLib.
+SET(COMPLEX_TEST_CMAKELIB 1)
+IF(CMAKE_TEST_DIFFERENT_GENERATOR)
+ SET(COMPLEX_TEST_CMAKELIB 0)
+ENDIF(CMAKE_TEST_DIFFERENT_GENERATOR)
+IF(CMAKE_TEST_SYSTEM_LIBRARIES)
+ SET(COMPLEX_TEST_CMAKELIB 0)
+ENDIF(CMAKE_TEST_SYSTEM_LIBRARIES)
+
#
# Define a macro
#