summaryrefslogtreecommitdiffstats
path: root/Tests/ComplexRelativePaths/CMakeLists.txt
diff options
context:
space:
mode:
authorBrad King <brad.king@kitware.com>2006-10-05 12:55:59 (GMT)
committerBrad King <brad.king@kitware.com>2006-10-05 12:55:59 (GMT)
commitc11cf31c9b70b21ba171bb2682ea5304e8d00de8 (patch)
tree3d6aaf2ef210a0a725346db4b708240d06edc06f /Tests/ComplexRelativePaths/CMakeLists.txt
parente36eb719135b8c5ce6ff317614df5e0d961718f2 (diff)
downloadCMake-c11cf31c9b70b21ba171bb2682ea5304e8d00de8.zip
CMake-c11cf31c9b70b21ba171bb2682ea5304e8d00de8.tar.gz
CMake-c11cf31c9b70b21ba171bb2682ea5304e8d00de8.tar.bz2
ENH: Adding SYSTEM option to INCLUDE_DIRECTORIES command. This addresses bug #3462.
Diffstat (limited to 'Tests/ComplexRelativePaths/CMakeLists.txt')
-rw-r--r--Tests/ComplexRelativePaths/CMakeLists.txt4
1 files changed, 2 insertions, 2 deletions
diff --git a/Tests/ComplexRelativePaths/CMakeLists.txt b/Tests/ComplexRelativePaths/CMakeLists.txt
index 3e5619f..90f4820 100644
--- a/Tests/ComplexRelativePaths/CMakeLists.txt
+++ b/Tests/ComplexRelativePaths/CMakeLists.txt
@@ -91,8 +91,8 @@ ENDIF(${fooCACHE_TEST_VAR2} MATCHES bar)
# Specify include and lib dirs
# (BEFORE is for coverage)
#
+INCLUDE_DIRECTORIES(SYSTEM Library)
INCLUDE_DIRECTORIES(
- Library
${Complex_SOURCE_DIR}/../../Source
${Complex_BINARY_DIR}/../../Source
)
@@ -101,7 +101,7 @@ INCLUDE_DIRECTORIES(BEFORE
${Complex_BINARY_DIR}
)
-INCLUDE_REGULAR_EXPRESSION("^(cmTest|file|sharedFile).*$" "^cmMissing")
+INCLUDE_REGULAR_EXPRESSION("^(cmTest|file|sharedFile|test).*$" "^cmMissing")
LINK_DIRECTORIES(
${Complex_BINARY_DIR}/Library