summaryrefslogtreecommitdiffstats
path: root/Tests/ComplexRelativePaths/Executable/CMakeLists.txt
diff options
context:
space:
mode:
authorBill Hoffman <bill.hoffman@kitware.com>2002-05-02 17:17:10 (GMT)
committerBill Hoffman <bill.hoffman@kitware.com>2002-05-02 17:17:10 (GMT)
commit27fe57b716555ffa31b16e98841c7f1a82228740 (patch)
tree361f44d30ef7bdba9c37b389824ac9670801177e /Tests/ComplexRelativePaths/Executable/CMakeLists.txt
parentb5b46599feb33d7f873faca6215f1717ddd209e6 (diff)
downloadCMake-27fe57b716555ffa31b16e98841c7f1a82228740.zip
CMake-27fe57b716555ffa31b16e98841c7f1a82228740.tar.gz
CMake-27fe57b716555ffa31b16e98841c7f1a82228740.tar.bz2
ENH: change LINK_LIBRARY to add to targets
Diffstat (limited to 'Tests/ComplexRelativePaths/Executable/CMakeLists.txt')
-rw-r--r--Tests/ComplexRelativePaths/Executable/CMakeLists.txt16
1 files changed, 5 insertions, 11 deletions
diff --git a/Tests/ComplexRelativePaths/Executable/CMakeLists.txt b/Tests/ComplexRelativePaths/Executable/CMakeLists.txt
index 30c60fe..72b77fa 100644
--- a/Tests/ComplexRelativePaths/Executable/CMakeLists.txt
+++ b/Tests/ComplexRelativePaths/Executable/CMakeLists.txt
@@ -5,22 +5,16 @@ CMAKE_MINIMUM_REQUIRED(VERSION 1.3)
SET(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -DTEST_CXX_FLAGS")
SET_SOURCE_FILES_PROPERTIES(complex COMPILE_FLAGS
"-DFILE_HAS_EXTRA_COMPILE_FLAGS")
-ADD_EXECUTABLE(complex complex)
-SET(COMPLEX_LIBS CMakeTestLibrary;CMakeTestLibraryShared;CMakeTestCLibraryShared)
-
+# Link to CMake lib
+LINK_DIRECTORIES(${Complex_BINARY_DIR}/../../Source)
# Use LINK_LIBRARIES instead of TARGET_LINK_LIBRARIES to
+SET(COMPLEX_LIBS CMakeTestLibrary;CMakeTestLibraryShared;CMakeTestCLibraryShared)
LINK_LIBRARIES(${COMPLEX_LIBS})
-#
-# Link to CMake lib
-# Specify the same one for debug/optimized to increase coverage
-#
-LINK_DIRECTORIES(${Complex_BINARY_DIR}/../../Source)
+ADD_EXECUTABLE(complex complex)
TARGET_LINK_LIBRARIES(complex
- CMakeLib
- debug CMakeLib
- optimized CMakeLib)
+ CMakeLib)
#
# Output the files required by 'complex' to a file.