summaryrefslogtreecommitdiffstats
path: root/Tests/ConfigSources/CMakeLists.txt
diff options
context:
space:
mode:
authorBrad King <brad.king@kitware.com>2014-12-01 13:55:45 (GMT)
committerBrad King <brad.king@kitware.com>2014-12-01 13:55:45 (GMT)
commit58d3898083e1bf66f4ecf2e82a556e81f67ce5bc (patch)
tree582d63921aab0ef0e91ebbb6913999418476fed2 /Tests/ConfigSources/CMakeLists.txt
parentbaa283f9226a8c599523e9265cb85b809740ab31 (diff)
parent8a75c7ef32af391cb45af889d266e2a77daa61d6 (diff)
downloadCMake-58d3898083e1bf66f4ecf2e82a556e81f67ce5bc.zip
CMake-58d3898083e1bf66f4ecf2e82a556e81f67ce5bc.tar.gz
CMake-58d3898083e1bf66f4ecf2e82a556e81f67ce5bc.tar.bz2
Merge branch 'target-sources-error-conditions' into release
Diffstat (limited to 'Tests/ConfigSources/CMakeLists.txt')
-rw-r--r--Tests/ConfigSources/CMakeLists.txt6
1 files changed, 3 insertions, 3 deletions
diff --git a/Tests/ConfigSources/CMakeLists.txt b/Tests/ConfigSources/CMakeLists.txt
index c272257..748aad8 100644
--- a/Tests/ConfigSources/CMakeLists.txt
+++ b/Tests/ConfigSources/CMakeLists.txt
@@ -5,9 +5,9 @@ project(ConfigSources)
add_library(iface INTERFACE)
set_property(TARGET iface PROPERTY INTERFACE_SOURCES
- iface_src.cpp
- $<$<CONFIG:Debug>:iface_debug_src.cpp>
- $<$<CONFIG:Release>:does_not_exist.cpp>
+ "${CMAKE_CURRENT_SOURCE_DIR}/iface_src.cpp"
+ "$<$<CONFIG:Debug>:${CMAKE_CURRENT_SOURCE_DIR}/iface_debug_src.cpp>"
+ "$<$<CONFIG:Release>:${CMAKE_CURRENT_SOURCE_DIR}/does_not_exist.cpp>"
)
add_executable(ConfigSources