summaryrefslogtreecommitdiffstats
path: root/Tests/CrossCompile/CMakeLists.txt
diff options
context:
space:
mode:
authorBrad King <brad.king@kitware.com>2012-08-14 12:31:45 (GMT)
committerCMake Topic Stage <kwrobot@kitware.com>2012-08-14 12:31:45 (GMT)
commitcd3bd23266a4a6c00595134a17a8bdaea9e28af5 (patch)
tree515fcf4fdee211067497339acb52de321640c4fc /Tests/CrossCompile/CMakeLists.txt
parent9acb4f118cd9a52aaa66897b1c0cd11dace3851c (diff)
parent68bc863d5bd64f3e893722e403d4fd56bd2e175a (diff)
downloadCMake-cd3bd23266a4a6c00595134a17a8bdaea9e28af5.zip
CMake-cd3bd23266a4a6c00595134a17a8bdaea9e28af5.tar.gz
CMake-cd3bd23266a4a6c00595134a17a8bdaea9e28af5.tar.bz2
Merge topic 'cleanup-style'
68bc863 Merge branch 'master' into cleanup-style a05eba5 CMakeVersion.bash: Update sed expression for lower-case 'set' 3c0488d Fix WarnUnusedUnusedViaUnset test pass/fail regex 6c2c483 Remove trailing TAB from NSIS.template.in 9db3116 Remove CMake-language block-end command arguments 77543bd Convert CMake-language commands to lower case 7bbaa42 Remove trailing whitespace from most CMake and C/C++ code be9db98 Merge topic 'watcom-compiler-version' af42ae4 Watcom: Simplify compiler version detection (#11866)
Diffstat (limited to 'Tests/CrossCompile/CMakeLists.txt')
-rw-r--r--Tests/CrossCompile/CMakeLists.txt12
1 files changed, 6 insertions, 6 deletions
diff --git a/Tests/CrossCompile/CMakeLists.txt b/Tests/CrossCompile/CMakeLists.txt
index 96a57a0..121cb81 100644
--- a/Tests/CrossCompile/CMakeLists.txt
+++ b/Tests/CrossCompile/CMakeLists.txt
@@ -1,13 +1,13 @@
cmake_minimum_required (VERSION 2.6)
-PROJECT(CrossCompile)
+project(CrossCompile)
-UNSET(run_result CACHE)
+unset(run_result CACHE)
#Simulate the cross compile condition
-SET(CMAKE_CROSSCOMPILING ON)
+set(CMAKE_CROSSCOMPILING ON)
-ADD_EXECUTABLE(CrossCompile main.c)
+add_executable(CrossCompile main.c)
-TRY_RUN(run_result compile_result
- ${CrossCompile_BINARY_DIR}
+try_run(run_result compile_result
+ ${CrossCompile_BINARY_DIR}
${CrossCompile_SOURCE_DIR}/main.c)