summaryrefslogtreecommitdiffstats
path: root/Tests/Cuda/CMakeLists.txt
diff options
context:
space:
mode:
authorRobert Maynard <robert.maynard@kitware.com>2018-10-22 14:54:44 (GMT)
committerBrad King <brad.king@kitware.com>2018-10-24 14:15:48 (GMT)
commit2cc050b53b4afb1ed62621360b860e25b7c46015 (patch)
treec2446498b1c4db63138987a8d62390c5c1478e34 /Tests/Cuda/CMakeLists.txt
parent83c13ca44f661ba22acf4abe63d84fd5651b4dbc (diff)
downloadCMake-2cc050b53b4afb1ed62621360b860e25b7c46015.zip
CMake-2cc050b53b4afb1ed62621360b860e25b7c46015.tar.gz
CMake-2cc050b53b4afb1ed62621360b860e25b7c46015.tar.bz2
CUDA: Add test for device linking when host linking uses threads
Convert the `CudaOnly.LinkSystemDeviceLibraries` test to a new `Cuda.ProperDeviceLibraries` test. The former covered only the `cublas_device` library which is removed by CUDA 10. Extend the new test to also cover various cases of using threads. Issue: #18008
Diffstat (limited to 'Tests/Cuda/CMakeLists.txt')
-rw-r--r--Tests/Cuda/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/Tests/Cuda/CMakeLists.txt b/Tests/Cuda/CMakeLists.txt
index 8a43df5..1b3daa6 100644
--- a/Tests/Cuda/CMakeLists.txt
+++ b/Tests/Cuda/CMakeLists.txt
@@ -4,5 +4,6 @@ ADD_TEST_MACRO(Cuda.ConsumeCompileFeatures CudaConsumeCompileFeatures)
ADD_TEST_MACRO(Cuda.ObjectLibrary CudaObjectLibrary)
ADD_TEST_MACRO(Cuda.MixedStandardLevels MixedStandardLevels)
ADD_TEST_MACRO(Cuda.ToolkitInclude CudaToolkitInclude)
+ADD_TEST_MACRO(Cuda.ProperDeviceLibraries ProperDeviceLibraries)
ADD_TEST_MACRO(Cuda.ProperLinkFlags ProperLinkFlags)
ADD_TEST_MACRO(Cuda.WithC CudaWithC)