summaryrefslogtreecommitdiffstats
path: root/Tests/Cuda/Complex/CMakeLists.txt
diff options
context:
space:
mode:
authorRaul Tambre <raul@tambre.ee>2020-09-20 14:11:33 (GMT)
committerRaul Tambre <raul@tambre.ee>2020-09-21 17:37:07 (GMT)
commit4fe9f534f522505f2609bac019ffcb8c6826a7b7 (patch)
treeb9f1a62b557240cce26ff57ce2b1067ebb6833ac /Tests/Cuda/Complex/CMakeLists.txt
parent39a5c0c82c2041a622bcdf19fa3f22abc34b9ae8 (diff)
downloadCMake-4fe9f534f522505f2609bac019ffcb8c6826a7b7.zip
CMake-4fe9f534f522505f2609bac019ffcb8c6826a7b7.tar.gz
CMake-4fe9f534f522505f2609bac019ffcb8c6826a7b7.tar.bz2
Tests: Don't unnecessarily set CUDA_ARCHITECTURES
Architecture 30 was removed with CUDA 11, so most of the CUDA tests fail with it. Remove setting the architecture and bump the minimum version to 3.18, so CMP0104 takes effect and we can rely on the default architecture, which is guaranteed to be compilable. Use of __ldg() in ProperLinkFlags was removed as it only affects performance and is available only on sm_35 and above. Testing the functionality of CUDA_ARCHITECTURES is already covered by CudaOnly.Architecture and CudaOnly.CompileFlags.
Diffstat (limited to 'Tests/Cuda/Complex/CMakeLists.txt')
-rw-r--r--Tests/Cuda/Complex/CMakeLists.txt7
1 files changed, 2 insertions, 5 deletions
diff --git a/Tests/Cuda/Complex/CMakeLists.txt b/Tests/Cuda/Complex/CMakeLists.txt
index 265bd85..63defdf 100644
--- a/Tests/Cuda/Complex/CMakeLists.txt
+++ b/Tests/Cuda/Complex/CMakeLists.txt
@@ -1,6 +1,5 @@
-
-cmake_minimum_required(VERSION 3.7)
-project (Complex CXX CUDA)
+cmake_minimum_required(VERSION 3.18)
+project(Complex CXX CUDA)
#Goal for this example:
#build a cpp dynamic library base
@@ -14,8 +13,6 @@ project (Complex CXX CUDA)
#this tests that we can properly handle linking cuda and cpp together
#and also building cpp targets that need cuda implicit libraries
-#verify that we can pass explicit cuda arch flags
-set(CMAKE_CUDA_ARCHITECTURES 30)
set(CMAKE_CUDA_STANDARD 11)
set(CMAKE_CXX_STANDARD 11)
set(CMAKE_CUDA_STANDARD_REQUIRED TRUE)