summaryrefslogtreecommitdiffstats
path: root/Tests/Cuda/ObjectLibrary/CMakeLists.txt
diff options
context:
space:
mode:
authorRobert Maynard <robert.maynard@kitware.com>2016-11-01 20:11:51 (GMT)
committerBrad King <brad.king@kitware.com>2016-11-14 21:40:50 (GMT)
commit7b9131da64b4b569e10ec145fab0c8e22fa69761 (patch)
treebf3cf32fa6515c1d197e7950262094290b797e6e /Tests/Cuda/ObjectLibrary/CMakeLists.txt
parent9cf5b98d54497b425fe341e4ad5bc188d9fa5445 (diff)
downloadCMake-7b9131da64b4b569e10ec145fab0c8e22fa69761.zip
CMake-7b9131da64b4b569e10ec145fab0c8e22fa69761.tar.gz
CMake-7b9131da64b4b569e10ec145fab0c8e22fa69761.tar.bz2
CUDA: Add tests to verify CUDA compiler works properly.
Diffstat (limited to 'Tests/Cuda/ObjectLibrary/CMakeLists.txt')
-rw-r--r--Tests/Cuda/ObjectLibrary/CMakeLists.txt12
1 files changed, 12 insertions, 0 deletions
diff --git a/Tests/Cuda/ObjectLibrary/CMakeLists.txt b/Tests/Cuda/ObjectLibrary/CMakeLists.txt
new file mode 100644
index 0000000..cbe1e67
--- /dev/null
+++ b/Tests/Cuda/ObjectLibrary/CMakeLists.txt
@@ -0,0 +1,12 @@
+cmake_minimum_required(VERSION 3.7)
+project (CudaObjectLibrary CUDA CXX)
+#Goal for this example:
+
+#build a object files some with cuda and some without than
+#embed these into an executable
+
+add_library(CudaMixedObjectLib OBJECT static.cu static.cpp)
+
+add_executable(CudaObjectLibrary
+ main.cpp
+ $<TARGET_OBJECTS:CudaMixedObjectLib>)