summaryrefslogtreecommitdiffstats
path: root/Tests/Cuda/ToolkitInclude/CMakeLists.txt
diff options
context:
space:
mode:
authorBrad King <brad.king@kitware.com>2017-02-14 13:30:30 (GMT)
committerCMake Topic Stage <kwrobot@kitware.com>2017-02-14 13:30:30 (GMT)
commitb7d8d80a62d2e2c31863efedd41945c2e9db9bcf (patch)
tree84a8e182a22b845bb5455d1e41fb0505820a9fe4 /Tests/Cuda/ToolkitInclude/CMakeLists.txt
parent31e96ccca23a034700e780470bf48cff0d7fd15e (diff)
parent44f3acb202c316bc6a863a1823aaafae486c899a (diff)
downloadCMake-b7d8d80a62d2e2c31863efedd41945c2e9db9bcf.zip
CMake-b7d8d80a62d2e2c31863efedd41945c2e9db9bcf.tar.gz
CMake-b7d8d80a62d2e2c31863efedd41945c2e9db9bcf.tar.bz2
Merge topic 'cmake_provide_include_dir_for_toolkit'
44f3acb2 CUDA: Detect the toolkit include directories
Diffstat (limited to 'Tests/Cuda/ToolkitInclude/CMakeLists.txt')
-rw-r--r--Tests/Cuda/ToolkitInclude/CMakeLists.txt11
1 files changed, 11 insertions, 0 deletions
diff --git a/Tests/Cuda/ToolkitInclude/CMakeLists.txt b/Tests/Cuda/ToolkitInclude/CMakeLists.txt
new file mode 100644
index 0000000..f246b54
--- /dev/null
+++ b/Tests/Cuda/ToolkitInclude/CMakeLists.txt
@@ -0,0 +1,11 @@
+cmake_minimum_required(VERSION 3.8)
+project (ToolkitInclude CXX CUDA)
+
+#Goal for this example:
+# Validate that between the CXX implicit include directories and the
+# CMAKE_CUDA_TOOLKIT_INCLUDE_DIRECTORIES directories we can find
+# the cuda runtime headers
+
+add_executable(CudaToolkitInclude main.cpp)
+target_include_directories(CudaToolkitInclude PRIVATE
+ ${CMAKE_CUDA_TOOLKIT_INCLUDE_DIRECTORIES})