summaryrefslogtreecommitdiffstats
path: root/Tests/CudaOnly/CMakeLists.txt
diff options
context:
space:
mode:
authorroot <raul@tambre.ee>2021-07-27 19:58:03 (GMT)
committerroot <raul@tambre.ee>2021-07-29 10:19:37 (GMT)
commit0b1cea66cd1f80458f0da579d0182d908874939d (patch)
tree182874aefd315752ab7a5e3c583a4a13d21e5ae4 /Tests/CudaOnly/CMakeLists.txt
parentf7cf69e34a1607e8ea2b6d10fef6a6058377c24e (diff)
downloadCMake-0b1cea66cd1f80458f0da579d0182d908874939d.zip
CMake-0b1cea66cd1f80458f0da579d0182d908874939d.tar.gz
CMake-0b1cea66cd1f80458f0da579d0182d908874939d.tar.bz2
CUDA/Clang: Fix separable compilation in non-root directories with Makefiles
Seems the relative paths were wrong basically all around such that only compiling files in the top-level directory would work. I've modified CudaOnly.SeparateCompilation to cover this. Fixes #22482.
Diffstat (limited to 'Tests/CudaOnly/CMakeLists.txt')
-rw-r--r--Tests/CudaOnly/CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/Tests/CudaOnly/CMakeLists.txt b/Tests/CudaOnly/CMakeLists.txt
index fdb7a6e..a3fb409 100644
--- a/Tests/CudaOnly/CMakeLists.txt
+++ b/Tests/CudaOnly/CMakeLists.txt
@@ -15,7 +15,7 @@ add_cuda_test_macro(CudaOnly.ToolkitBeforeLang CudaOnlyToolkitBeforeLang)
add_cuda_test_macro(CudaOnly.WithDefs CudaOnlyWithDefs)
add_cuda_test_macro(CudaOnly.CircularLinkLine CudaOnlyCircularLinkLine)
add_cuda_test_macro(CudaOnly.ResolveDeviceSymbols CudaOnlyResolveDeviceSymbols)
-add_cuda_test_macro(CudaOnly.SeparateCompilation CudaOnlySeparateCompilation)
+add_cuda_test_macro(CudaOnly.SeparateCompilation main/CudaOnlySeparateCompilation)
if(CMake_TEST_CUDA AND NOT CMake_TEST_CUDA STREQUAL "Clang")
# Clang doesn't have flags for selecting the runtime.