summaryrefslogtreecommitdiffstats
path: root/Tests/CudaOnly/CMakeLists.txt
diff options
context:
space:
mode:
authorBrad King <brad.king@kitware.com>2018-04-13 16:38:08 (GMT)
committerBrad King <brad.king@kitware.com>2018-04-13 16:56:36 (GMT)
commit134e795fa968a06e289f1449b6ca4bf4702da03b (patch)
tree25014da053bc985cbbaebf673393bf21d184f3f1 /Tests/CudaOnly/CMakeLists.txt
parent77705a2c2834e84a7413e01e5575201d1730b57a (diff)
downloadCMake-134e795fa968a06e289f1449b6ca4bf4702da03b.zip
CMake-134e795fa968a06e289f1449b6ca4bf4702da03b.tar.gz
CMake-134e795fa968a06e289f1449b6ca4bf4702da03b.tar.bz2
VS: Add workaround for CUDA compiler PDB location
The CUDA Toolkit Visual Studio Integration does not honor the `ClCompile.ProgramDataBaseFileName` field when telling `nvcc` how to invoke `cl`. Work around this problem by passing `-Xcompiler=-Fd...` ourselves through `AdditionalOptions`. Fixes: #17647
Diffstat (limited to 'Tests/CudaOnly/CMakeLists.txt')
-rw-r--r--Tests/CudaOnly/CMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/Tests/CudaOnly/CMakeLists.txt b/Tests/CudaOnly/CMakeLists.txt
index 565baca..59f3e84 100644
--- a/Tests/CudaOnly/CMakeLists.txt
+++ b/Tests/CudaOnly/CMakeLists.txt
@@ -6,3 +6,7 @@ ADD_TEST_MACRO(CudaOnly.LinkSystemDeviceLibraries CudaOnlyLinkSystemDeviceLibrar
ADD_TEST_MACRO(CudaOnly.ResolveDeviceSymbols CudaOnlyResolveDeviceSymbols)
ADD_TEST_MACRO(CudaOnly.SeparateCompilation CudaOnlySeparateCompilation)
ADD_TEST_MACRO(CudaOnly.WithDefs CudaOnlyWithDefs)
+
+if(MSVC)
+ ADD_TEST_MACRO(CudaOnly.PDB CudaOnlyPDB)
+endif()