summaryrefslogtreecommitdiffstats
path: root/Tests/CudaOnly/GPUDebugFlag/CMakeLists.txt
diff options
context:
space:
mode:
authorBrad King <brad.king@kitware.com>2018-01-12 14:51:37 (GMT)
committerKitware Robot <kwrobot@kitware.com>2018-01-12 14:51:42 (GMT)
commit46ad7215979cd60c00589f6f0abdcff2856069e8 (patch)
tree887bbce2d77e35a7371ae003baec6155b3d14c01 /Tests/CudaOnly/GPUDebugFlag/CMakeLists.txt
parentaf56d7f5999a1ead7916fa6e65ed8db88b1f5ab7 (diff)
parentdcc606ad47d61ab37e7ab520aafabc9731f088f1 (diff)
downloadCMake-46ad7215979cd60c00589f6f0abdcff2856069e8.zip
CMake-46ad7215979cd60c00589f6f0abdcff2856069e8.tar.gz
CMake-46ad7215979cd60c00589f6f0abdcff2856069e8.tar.bz2
Merge topic 'cuda_allow_G_to_device_debugging_on_msvc'
dcc606ad CUDA: Allow -G to control device debuging on MSVC. Acked-by: Kitware Robot <kwrobot@kitware.com> Merge-request: !1619
Diffstat (limited to 'Tests/CudaOnly/GPUDebugFlag/CMakeLists.txt')
-rw-r--r--Tests/CudaOnly/GPUDebugFlag/CMakeLists.txt23
1 files changed, 23 insertions, 0 deletions
diff --git a/Tests/CudaOnly/GPUDebugFlag/CMakeLists.txt b/Tests/CudaOnly/GPUDebugFlag/CMakeLists.txt
new file mode 100644
index 0000000..5b96906
--- /dev/null
+++ b/Tests/CudaOnly/GPUDebugFlag/CMakeLists.txt
@@ -0,0 +1,23 @@
+
+cmake_minimum_required(VERSION 3.7)
+project (CudaOnlGPUDebugFlag CUDA)
+
+#Goal for this example:
+#verify that -G enables gpu debug flags
+string(APPEND CMAKE_CUDA_FLAGS " -gencode=arch=compute_30,code=compute_30")
+string(APPEND CMAKE_CUDA_FLAGS " -G")
+set(CMAKE_CUDA_STANDARD 11)
+
+add_executable(CudaOnlyGPUDebugFlag main.cu)
+
+if(CMAKE_CUDA_COMPILER_VERSION VERSION_LESS 9.0.0)
+ #CUDA's __CUDACC_DEBUG__ define was added in 9.0
+ #so if we are below 9.0.0 we will manually add the define so that the test
+ #passes
+ target_compile_definitions(CudaOnlyGPUDebugFlag PRIVATE "__CUDACC_DEBUG__")
+endif()
+
+if(APPLE)
+ # Help the static cuda runtime find the driver (libcuda.dyllib) at runtime.
+ set_property(TARGET CudaOnlyGPUDebugFlag PROPERTY BUILD_RPATH ${CMAKE_CUDA_IMPLICIT_LINK_DIRECTORIES})
+endif()