summaryrefslogtreecommitdiffstats
path: root/Tests/CudaOnly/LinkSystemDeviceLibraries/CMakeLists.txt
diff options
context:
space:
mode:
authorRobert Maynard <robert.maynard@kitware.com>2018-10-22 14:54:44 (GMT)
committerBrad King <brad.king@kitware.com>2018-10-24 14:15:48 (GMT)
commit2cc050b53b4afb1ed62621360b860e25b7c46015 (patch)
treec2446498b1c4db63138987a8d62390c5c1478e34 /Tests/CudaOnly/LinkSystemDeviceLibraries/CMakeLists.txt
parent83c13ca44f661ba22acf4abe63d84fd5651b4dbc (diff)
downloadCMake-2cc050b53b4afb1ed62621360b860e25b7c46015.zip
CMake-2cc050b53b4afb1ed62621360b860e25b7c46015.tar.gz
CMake-2cc050b53b4afb1ed62621360b860e25b7c46015.tar.bz2
CUDA: Add test for device linking when host linking uses threads
Convert the `CudaOnly.LinkSystemDeviceLibraries` test to a new `Cuda.ProperDeviceLibraries` test. The former covered only the `cublas_device` library which is removed by CUDA 10. Extend the new test to also cover various cases of using threads. Issue: #18008
Diffstat (limited to 'Tests/CudaOnly/LinkSystemDeviceLibraries/CMakeLists.txt')
-rw-r--r--Tests/CudaOnly/LinkSystemDeviceLibraries/CMakeLists.txt15
1 files changed, 0 insertions, 15 deletions
diff --git a/Tests/CudaOnly/LinkSystemDeviceLibraries/CMakeLists.txt b/Tests/CudaOnly/LinkSystemDeviceLibraries/CMakeLists.txt
deleted file mode 100644
index 7f7f606..0000000
--- a/Tests/CudaOnly/LinkSystemDeviceLibraries/CMakeLists.txt
+++ /dev/null
@@ -1,15 +0,0 @@
-cmake_minimum_required(VERSION 3.8)
-project(LinkSystemDeviceLibraries CUDA)
-
-string(APPEND CMAKE_CUDA_FLAGS " -gencode arch=compute_35,code=compute_35 -gencode arch=compute_35,code=sm_35")
-set(CMAKE_CUDA_STANDARD 11)
-
-add_executable(CudaOnlyLinkSystemDeviceLibraries main.cu)
-set_target_properties( CudaOnlyLinkSystemDeviceLibraries
- PROPERTIES CUDA_SEPARABLE_COMPILATION ON)
-target_link_libraries( CudaOnlyLinkSystemDeviceLibraries PRIVATE cublas_device)
-
-if(APPLE)
- # Help the static cuda runtime find the driver (libcuda.dyllib) at runtime.
- set_property(TARGET CudaOnlyLinkSystemDeviceLibraries PROPERTY BUILD_RPATH ${CMAKE_CUDA_IMPLICIT_LINK_DIRECTORIES})
-endif()