summaryrefslogtreecommitdiffstats
path: root/Tests/CustComDepend/CMakeLists.txt
diff options
context:
space:
mode:
authorBill Hoffman <bill.hoffman@kitware.com>2006-12-07 04:05:10 (GMT)
committerBill Hoffman <bill.hoffman@kitware.com>2006-12-07 04:05:10 (GMT)
commit26b527ac0fd63d2a86d3552122bd44a5b32d6adb (patch)
tree1d512054b9db82a4dd45aa839faf29fd737f6ae0 /Tests/CustComDepend/CMakeLists.txt
parenta44ac0719ca0919aec649fec7a9b8e592b925b0b (diff)
downloadCMake-26b527ac0fd63d2a86d3552122bd44a5b32d6adb.zip
CMake-26b527ac0fd63d2a86d3552122bd44a5b32d6adb.tar.gz
CMake-26b527ac0fd63d2a86d3552122bd44a5b32d6adb.tar.bz2
ENH: fix bug in full path to target depends stuff
Diffstat (limited to 'Tests/CustComDepend/CMakeLists.txt')
-rw-r--r--Tests/CustComDepend/CMakeLists.txt11
1 files changed, 11 insertions, 0 deletions
diff --git a/Tests/CustComDepend/CMakeLists.txt b/Tests/CustComDepend/CMakeLists.txt
new file mode 100644
index 0000000..0f2c763
--- /dev/null
+++ b/Tests/CustComDepend/CMakeLists.txt
@@ -0,0 +1,11 @@
+project(CustComDepend)
+add_definitions(-D_CRT_SECURE_NO_DEPRECATE=1)
+set(EXECUTABLE_OUTPUT_PATH ${CustComDepend_BINARY_DIR}/bin)
+add_executable(foo foo.cxx)
+add_custom_command(
+ OUTPUT ${CustComDepend_BINARY_DIR}/bar.c
+ COMMAND ${CustComDepend_BINARY_DIR}/bin/foo ${CustComDepend_BINARY_DIR}/bar.c
+ DEPENDS ${CustComDepend_BINARY_DIR}/bin/${CMAKE_CFG_INTDIR}/foo
+)
+
+add_library(bar SHARED ${CustComDepend_BINARY_DIR}/bar.c)