summaryrefslogtreecommitdiffstats
path: root/Tests/CustomCommand/CMakeLists.txt
diff options
context:
space:
mode:
authorBrad King <brad.king@kitware.com>2010-12-15 13:44:57 (GMT)
committerBrad King <brad.king@kitware.com>2010-12-15 13:44:57 (GMT)
commita75a0a14484a7f11961430006fad602099d22f6c (patch)
tree2aff1ede3944933566b1908e3e84929c6f6b8c63 /Tests/CustomCommand/CMakeLists.txt
parenta14a8562ea5f321b0a8f6f61f4c457da298825c5 (diff)
downloadCMake-a75a0a14484a7f11961430006fad602099d22f6c.zip
CMake-a75a0a14484a7f11961430006fad602099d22f6c.tar.gz
CMake-a75a0a14484a7f11961430006fad602099d22f6c.tar.bz2
Normalize add_custom_command OUTPUT names (#10485)
Previously the OUTPUT arguments of add_custom_command were not slash-normalized but those of add_library and add_executable were. This caused the example add_custom_command(OUTPUT a//b.c ...) add_library(... a//b.c ...) to fail at build time with "no rule to make a/b.c". Fix this and modify the CustomCommand test to try it.
Diffstat (limited to 'Tests/CustomCommand/CMakeLists.txt')
-rw-r--r--Tests/CustomCommand/CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/Tests/CustomCommand/CMakeLists.txt b/Tests/CustomCommand/CMakeLists.txt
index 746c9a7..13f4233 100644
--- a/Tests/CustomCommand/CMakeLists.txt
+++ b/Tests/CustomCommand/CMakeLists.txt
@@ -55,7 +55,7 @@ ADD_CUSTOM_COMMAND(
# Test creating files from a custom target
#
################################################################
-ADD_CUSTOM_COMMAND(OUTPUT ${PROJECT_BINARY_DIR}/doc1.dvi
+ADD_CUSTOM_COMMAND(OUTPUT ${PROJECT_BINARY_DIR}//doc1.dvi # test 2 slashes
DEPENDS ${PROJECT_SOURCE_DIR}/doc1.tex
COMMAND ${CMAKE_COMMAND}
ARGS -E copy ${PROJECT_SOURCE_DIR}/doc1.tex