summaryrefslogtreecommitdiffstats
path: root/Tests/CustomCommand/CMakeLists.txt
diff options
context:
space:
mode:
authorBrad King <brad.king@kitware.com>2008-10-09 15:01:23 (GMT)
committerBrad King <brad.king@kitware.com>2008-10-09 15:01:23 (GMT)
commitc5f70ff27fb7ea9d2421b4cc25e303f171612525 (patch)
tree37012c7d62a1d729b70437e867a4fe3f83c6dc7d /Tests/CustomCommand/CMakeLists.txt
parent0ad5eb177b4b1f56c1ae29445575dc63d4ddf0eb (diff)
downloadCMake-c5f70ff27fb7ea9d2421b4cc25e303f171612525.zip
CMake-c5f70ff27fb7ea9d2421b4cc25e303f171612525.tar.gz
CMake-c5f70ff27fb7ea9d2421b4cc25e303f171612525.tar.bz2
ENH: Allow custom sources in custom targets
This adds a SOURCES option to ADD_CUSTOM_TARGET, enabling users to specify extra sources for inclusion in the target. Such sources may not build, but will show up in the IDE project files for convenient editing. See issue #5848.
Diffstat (limited to 'Tests/CustomCommand/CMakeLists.txt')
-rw-r--r--Tests/CustomCommand/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/Tests/CustomCommand/CMakeLists.txt b/Tests/CustomCommand/CMakeLists.txt
index b8410e1..8ac1f12 100644
--- a/Tests/CustomCommand/CMakeLists.txt
+++ b/Tests/CustomCommand/CMakeLists.txt
@@ -100,6 +100,7 @@ ADD_CUSTOM_TARGET(TDocument ALL
${PROJECT_BINARY_DIR}/doc2.h
DEPENDS ${PROJECT_BINARY_DIR}/doc1.h doc1.txt
COMMENT "Running top-level TDocument commands"
+ SOURCES doc1.tex
)
# Setup a pre- and post-build pair that will fail if not run in the