summaryrefslogtreecommitdiffstats
path: root/Tests/CxxOnly/CMakeLists.txt
diff options
context:
space:
mode:
authorBill Hoffman <bill.hoffman@kitware.com>2010-09-02 15:56:40 (GMT)
committerBill Hoffman <bill.hoffman@kitware.com>2010-09-02 15:56:40 (GMT)
commitced61f5722d65525fd4b8dbf96d5ea8f254099c2 (patch)
tree00c5e10e7a53c7689ec7d560fb348e5edd03e2ec /Tests/CxxOnly/CMakeLists.txt
parentf9436016401416b21f6dfc30b5a548c909f649bb (diff)
downloadCMake-ced61f5722d65525fd4b8dbf96d5ea8f254099c2.zip
CMake-ced61f5722d65525fd4b8dbf96d5ea8f254099c2.tar.gz
CMake-ced61f5722d65525fd4b8dbf96d5ea8f254099c2.tar.bz2
Let CMake recognize .CPP .CXX and .C++ as c++ files.
Diffstat (limited to 'Tests/CxxOnly/CMakeLists.txt')
-rw-r--r--Tests/CxxOnly/CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/Tests/CxxOnly/CMakeLists.txt b/Tests/CxxOnly/CMakeLists.txt
index bfc8271..8418ad9 100644
--- a/Tests/CxxOnly/CMakeLists.txt
+++ b/Tests/CxxOnly/CMakeLists.txt
@@ -2,7 +2,7 @@
project (CxxOnly CXX)
set(CMAKE_DEBUG_POSTFIX "_test_debug_postfix")
-add_library(testcxx1 STATIC libcxx1.cxx)
+add_library(testcxx1 STATIC libcxx1.cxx test.CPP test.CXX test.C++)
add_library(testcxx2 SHARED libcxx2.cxx)
add_executable (CxxOnly cxxonly.cxx)
target_link_libraries(CxxOnly testcxx1 testcxx2)