summaryrefslogtreecommitdiffstats
path: root/Tests/CxxOnly/CMakeLists.txt
diff options
context:
space:
mode:
authorBrad King <brad.king@kitware.com>2010-09-14 19:05:09 (GMT)
committerBrad King <brad.king@kitware.com>2010-09-14 19:05:09 (GMT)
commiteccc7d5d267d7dc4eab027fab54ef4e7a63c8d4f (patch)
treeb0ab46080ec15fc066b57f0606d70fb9fc9756b4 /Tests/CxxOnly/CMakeLists.txt
parented37fc3ea398b03bbba175ae337f14b6af58daee (diff)
parent7944e4e0ac37cb1423da2de7a203557b77372aac (diff)
downloadCMake-eccc7d5d267d7dc4eab027fab54ef4e7a63c8d4f.zip
CMake-eccc7d5d267d7dc4eab027fab54ef4e7a63c8d4f.tar.gz
CMake-eccc7d5d267d7dc4eab027fab54ef4e7a63c8d4f.tar.bz2
Merge branch 'allow_upper_case_cpp_and_others' into resolve/fix_target_name_with_dot_vs10/allow_upper_case_cpp_and_others
Conflicts: Tests/CxxOnly/CMakeLists.txt
Diffstat (limited to 'Tests/CxxOnly/CMakeLists.txt')
-rw-r--r--Tests/CxxOnly/CMakeLists.txt5
1 files changed, 4 insertions, 1 deletions
diff --git a/Tests/CxxOnly/CMakeLists.txt b/Tests/CxxOnly/CMakeLists.txt
index 0b2c1c5..5d27890 100644
--- a/Tests/CxxOnly/CMakeLists.txt
+++ b/Tests/CxxOnly/CMakeLists.txt
@@ -2,7 +2,10 @@
project (CxxOnly CXX)
set(CMAKE_DEBUG_POSTFIX "_test_debug_postfix")
-add_library(testcxx1.my STATIC libcxx1.cxx test.CPP)
+if(WIN32)
+ set(EXTRA_SRCS test.CPP)
+endif()
+add_library(testcxx1.my STATIC libcxx1.cxx ${EXTRA_SRCS})
add_library(testcxx2 SHARED libcxx2.cxx)
add_executable (CxxOnly cxxonly.cxx)
target_link_libraries(CxxOnly testcxx1.my testcxx2)