summaryrefslogtreecommitdiffstats
path: root/Tests/CxxOnly/CMakeLists.txt
diff options
context:
space:
mode:
authorBill Hoffman <bill.hoffman@kitware.com>2010-09-06 16:43:57 (GMT)
committerBill Hoffman <bill.hoffman@kitware.com>2010-09-06 16:43:57 (GMT)
commitba0a8905395ec7e616bbedee33a83fcf15a86910 (patch)
tree5b49f021a56bb58bbfdc6a58af6e43c99303d0e1 /Tests/CxxOnly/CMakeLists.txt
parentd26cd46989b4e1170cbebc97ae3b6b30395158db (diff)
downloadCMake-ba0a8905395ec7e616bbedee33a83fcf15a86910.zip
CMake-ba0a8905395ec7e616bbedee33a83fcf15a86910.tar.gz
CMake-ba0a8905395ec7e616bbedee33a83fcf15a86910.tar.bz2
Only test for .CPP on Microsoft compilers which will handle .CPP as c++.
Diffstat (limited to 'Tests/CxxOnly/CMakeLists.txt')
-rw-r--r--Tests/CxxOnly/CMakeLists.txt5
1 files changed, 4 insertions, 1 deletions
diff --git a/Tests/CxxOnly/CMakeLists.txt b/Tests/CxxOnly/CMakeLists.txt
index 8258eb4..4654f44 100644
--- a/Tests/CxxOnly/CMakeLists.txt
+++ b/Tests/CxxOnly/CMakeLists.txt
@@ -2,7 +2,10 @@
project (CxxOnly CXX)
set(CMAKE_DEBUG_POSTFIX "_test_debug_postfix")
-add_library(testcxx1 STATIC libcxx1.cxx test.CPP)
+if(MSVC)
+ set(EXTRA_SRCS test.CPP)
+endif()
+add_library(testcxx1 STATIC libcxx1.cxx ${EXTRA_SRCS})
add_library(testcxx2 SHARED libcxx2.cxx)
add_executable (CxxOnly cxxonly.cxx)
target_link_libraries(CxxOnly testcxx1 testcxx2)