summaryrefslogtreecommitdiffstats
path: root/Tests/CxxOnly/CMakeLists.txt
diff options
context:
space:
mode:
authorBrad King <brad.king@kitware.com>2020-06-12 14:06:31 (GMT)
committerKitware Robot <kwrobot@kitware.com>2020-06-12 14:06:37 (GMT)
commit5b6f08f19274e2aa8aff27aea26caf8e1fafcdbd (patch)
treee07bd93ebfc1038080e9c777e6107009f8fb5e96 /Tests/CxxOnly/CMakeLists.txt
parent82c402ed34a55c64335d8c870fa669162b6a8698 (diff)
parent5c04e77e0792c0a704ec4d7c2bb228750d37d060 (diff)
downloadCMake-5b6f08f19274e2aa8aff27aea26caf8e1fafcdbd.zip
CMake-5b6f08f19274e2aa8aff27aea26caf8e1fafcdbd.tar.gz
CMake-5b6f08f19274e2aa8aff27aea26caf8e1fafcdbd.tar.bz2
Merge topic 'vs-lang-C'
5c04e77e07 VS: Restore compilation of '.C' sources as C++ Acked-by: Kitware Robot <kwrobot@kitware.com> Merge-request: !4880
Diffstat (limited to 'Tests/CxxOnly/CMakeLists.txt')
-rw-r--r--Tests/CxxOnly/CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/Tests/CxxOnly/CMakeLists.txt b/Tests/CxxOnly/CMakeLists.txt
index e62f3c7..8207dd1 100644
--- a/Tests/CxxOnly/CMakeLists.txt
+++ b/Tests/CxxOnly/CMakeLists.txt
@@ -5,7 +5,7 @@ set(CMAKE_DEBUG_POSTFIX "_test_debug_postfix")
if(WIN32)
set(EXTRA_SRCS test.CPP)
endif()
-add_library(testcxx1.my STATIC libcxx1.cxx ${EXTRA_SRCS})
+add_library(testcxx1.my STATIC libcxx1.cxx test.C ${EXTRA_SRCS})
add_library(testcxx2 SHARED libcxx2.cxx)
add_executable (CxxOnly cxxonly.cxx)
target_link_libraries(CxxOnly testcxx1.my testcxx2)