summaryrefslogtreecommitdiffstats
path: root/Tests/CxxOnly/CMakeLists.txt
diff options
context:
space:
mode:
authorBrad King <brad.king@kitware.com>2006-07-21 15:43:26 (GMT)
committerBrad King <brad.king@kitware.com>2006-07-21 15:43:26 (GMT)
commit673e3f8964f124d65731a93fb5fdc8d6fa760ec4 (patch)
treebba3378e0028a2a564b516a46dd9d13b19aaf8c5 /Tests/CxxOnly/CMakeLists.txt
parent0189ce3424e15aaa82e61c7f05875062b8d25ca1 (diff)
downloadCMake-673e3f8964f124d65731a93fb5fdc8d6fa760ec4.zip
CMake-673e3f8964f124d65731a93fb5fdc8d6fa760ec4.tar.gz
CMake-673e3f8964f124d65731a93fb5fdc8d6fa760ec4.tar.bz2
ENH: Adding C++-only test.
Diffstat (limited to 'Tests/CxxOnly/CMakeLists.txt')
-rw-r--r--Tests/CxxOnly/CMakeLists.txt8
1 files changed, 8 insertions, 0 deletions
diff --git a/Tests/CxxOnly/CMakeLists.txt b/Tests/CxxOnly/CMakeLists.txt
new file mode 100644
index 0000000..cf31474
--- /dev/null
+++ b/Tests/CxxOnly/CMakeLists.txt
@@ -0,0 +1,8 @@
+# a simple CXX only test case
+project (cxxonly CXX)
+
+set(CMAKE_DEBUG_POSTFIX "_test_debug_postfix")
+add_library(testcxx1 STATIC libcxx1.cxx)
+add_library(testcxx2 SHARED libcxx2.cxx)
+add_executable (cxxonly cxxonly.cxx)
+target_link_libraries(cxxonly testcxx1 testcxx2)